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Introduction

Safety Guidelines

This manual contains notices intended to ensure personal safety, as well as to protect the products and connected
equipment against damage. These notices are highlighted by the symbols shown below and graded according to
severity by the following texts:

Danger
indicates that death, severe personal injury or substantial property damage will result if proper precautions are not
taken.

Warning
indicates that death, severe personal injury or substantial property damage can result if proper precautions are not
taken.

Caution
indicates that minor personal injury can result if proper precautions are not taken.

Caution
indicates that property damage can result if proper precautions are not taken.

Notice
draws your attention to particularly important information on the product, handling the product, or to a particular part of
the documentation.

Qualified Personnel

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons are defined as
persons who are authorized to commission, to ground and to tag circuits, equipment, and systems in accordance with
established safety practices and standards.

Correct Usage
Note the following:

Warning

This device and its components may only be used for the applications described in the catalog or the technical des-
cription, and only in connection with devices or components from other manufacturers which have been approved or
recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed correctly, and
operated and maintained as recommended.

Trademarks

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.
Third parties using for their own purposes any other names in this document which refer to trademarks might infringe
upon the rights of the trademark owners.

Copyright © Siemens AG 2004 All rights reserved Disclaimer of Liability

The reproduction, transmission or use of this We have checked the contents of this manual for agreement with the
document or its contents is not permitted without express hardware and software described. Since deviations cannot be

written authority. Offenders will be liable for damages. All precluded entirely, we cannot guarantee full agreement. However, the
rights, including rights created by patent grant or data in this manual are reviewed regularly and any necessary
registration of a utility model or design, are reserved. corrections included in subsequent editions. Suggestions for

improvement are welcomed.

Siemens AG
Bereich Automation and Drives ©Siemens AG 2004
Geschaeftsgebiet Industrial Automation Systems Technical data subject to change.

Postfach 4848, D- 90327 Nuernberg

Siemens Aktiengesellschaft A5E00293886
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Welcome to STEP 7 Lite

... the SIMATIC software for generating PLC programs in LAD, FBD or STL for SIMATIC S7-300 (including
SIMATIC C7), ET 200S and ET 200X. STEP 7 Lite is designed for the newcomer to SIMATIC as well as for
the user editing projects offline.

You will need basic STEP 7 software or STEP 7 Professional if you want to implement a SIMATIC S7-400
PLC, distributed 1/O, CP communication modules, FM function modules, or systems consisting of more than
one CPU.

Information on STEP 7 Lite

STEP 7 Lite is a software not only designed for newcomers, but also for the expert who primarily programs
medium performance systems. With STEP 7, programs created in STEP 7 Lite can be imported/exported for
further use. Compared to STEP 7, we went new ways in designing the user interface. Enhanced Explorer
functions, transparent project overviews and the usual Windows operating philosophy, all of which will offer
optimal support to you for getting started and working with our SIMATIC Software.

Information on this Getting Started

Here you will get to know the basics of STEP 7 Lite. We shall guide you through practical exercises introdu-
cing you to essential on-screen dialogs and operating procedures, prepared in such a way that you can start
at almost any chapter. Descriptions and operating procedures you should refer or which you must follow are
highlighted in red color. Brief excursions to associated topics are referenced in blue color.

Prerequisites for working with this Getting Started

What you need to work through the practical STEP 7 Lite exercises in this Getting Started:
» a SIMATIC PG or a PC,

» the STEP 7 Lite software package and the authorization disk,

+ a SIMATIC S7-300 PLC.
Please note the Order No. table in Chapter 1.

Further Documentation

» After installation of STEP 7 Lite, select Start > Simatic > Documentation on your CD to open and print
the electronic manual "Programming with STEP 7 Lite".

Have lots of fun and success!

SIEMENS AG
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Introduction

Overview of the Getting Started
Sample Projects

After installing your STEP 7 Lite software, unless you have selected another directory, go to
<Drive>:\Siemens\S7lite\Examples\English ... to find the programming samples to follow.

This Getting Started refers to these samples:

. first_stepd_stl.k7p
. first_steps_fdb.k7p

. first_steps_lad.k7p

All sample programs are identical, differing only in the programming language you choose to work with.
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Overview and installation

What are you going to learn?

Practical exercises in this manual will
show you how easy it is to handle the
programming languages LAD (Ladder
logic), FBD (Function block diagram)

and STL (Statement list) in

STEP 7 Lite.

Start by creating a project. Name it
“Getting Started”.

Next, you will create a PLC program in
this project, using the simple binary
logical operations AND, OR, MEMORY
CIRCUIT.

You are then going to enhance this

PLC program to operate a motor testing
bench.
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Basic know-how

Our programming examples are based
on three fundamental, binary
logical operations:

Series circuit

The first binary logical operation you
are then going to program is an AND
function. The AND function can be
demonstrated by an electrical circuit
that is equipped with two pushbuttons.

The lamp is lit when pushbutton 1 AND
2 are pressed.

Parallel circuit

The second binary logical link is the
OR function which can also be demon-
strated in an electrical circuit.

The lamp is lit when pushbutton 3 OR 4
is pressed.

Memory circuit

(Set/reset flipflop)

The third binary logical operation is the
memory circuit. In an electrical circuit it
responds to certain voltage levels and
outputs these accordingly.

Press pushbutton S. The lamp remains
lit until pushbutton R is pressed.

You are going to program all three
binary logical operations to form a
practical sample circuit — a motor
bench. You will learn how to handle fol-
lowing STEP 7 Lite program elements:
Organization blocks, function blocks,
instance data blocks, functions, global
data blocks.

Getting Started STEP 7 Lite A5E00293886-01

13



Overview and installation

Interaction between
hardware and software

Transfering a project
Progamming device

Machine to be controlled

: (can be simulated with
STEP 7 Lite Software S7-PLCSIM)

Power supply

either an MPI cable
between PG/PC and
PLC

Memory module

or a PC adapter and
zero modem cable

(RS-232)
Using the STEP 7 Lite software, you
are going to create your user program
Power supply module in a project.

The programmable controller (PLC)
CPU consists of a rack, a power supply, a
CPU and input or output modules.

Input module The PLC monitors and controls your
machine with the help of the user
program.

Output module I/0 modules are addressed in the user
program via I/O addresses.

Getting Started STEP 7 Lite A5E00293886-01



PLC station e

Order numbers:

Power supply (PS 307 2A) 6ES7307-1BA00-0AA0
CPU (CPU 315) 6ES7315-1AF03-0AB0
Digit input (SM32DI 16xDC24V) 6ES7321-1BH02-0AA0

Digital output (SM322 DO 16xDC24V/0,5A)
6ES7322-1BH01-0AAQ

Backup battery (Li) 3,4V 6ES7971-1AA00-0AA0
Profile rail 480 mm 6ES7390-1AE80-0AAQD
Computer Q
SIMATIC PG www.ad.siemens.de/

Power PG, Field PG or simatic-pg
Commonly available PC

with CP 5611
Operating system

Windows 2000 or

Windows XP Home or Professional Edition
Internet Explorer as of V6.0

Software e

Software
STEP 7 Lite (Floating License) 6ES7810-3CC07-0YA5

Documentation

First Steps with STEP 7 Lite V3.0

Options package

Simulation software S7-PLCSIM 6ES7841-0CC04-0YAS
(Floating License)

Simulation software S7-PLCSIM 6ES7841-0CC04-0YES
(Upgrade)

Component Checklist

You require the following components
to create the sample project described
above.

STEP 7 Lite lets you program compo-
nents of the S7-300, ET 200S and ET
200X series. The modules used in the
sample project are listed in brackets.
Of course, you are free to use other
modules of these series.

We recommend you use our SIMATIC
PGs. These units can withstand

harsh industrial environments.

You will need an additional interface
cable if you decide to use a commonly
available PC. This interface is already
integrated in SIMATIC PGs.

Notes on installation are found on the
CD, in STEP7Lite\Disk1\README.WRI.

This "First Steps with STEP 7 Lite”
manual is supplied with a software CD
that also contains the

electronic manual "Programming with
STEP 7 Lite” and the Online Help.

S7-PLCSIM simulates a connected
PLC. S7-PLCSIM is helpful if you want
to run a program test without having
local access to hardware.

Getting Started STEP 7 Lite A5E00293886-01
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Overview and installation

STEP 7 Lite

Designing the solution of an automation task
chapter 3

¥

Configuring the hardware

chapter/4

6 &

Creating a program

chapter 5 -9

¥

Transfering program
to CPU

chapter 10

¥

Testing the program

chapter 11
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A project represents the central
element in STEP 7 Lite. Within this
project you solve all your automation
tasks — starting at the hardware
configuration and working your way to
the program test run.

We recommend you configure your hardware first
before you run large programs with many 1/Os. In
this case, you will have the advantage that

STEP 7 Lite displays available addresses in
Hardware Configuration.

When you choose to start by writing the program,
you would rather have to determine available
addresses by yourself according to the selected
component, as in this case you could not call
them via STEP 7 Lite.

Hardware Configuration not only lets you specify
addresses, but also allows you to edit module
parameters and characteristics.

If you prefer to start programming right away you
can skip hardware configuration, as this "Getting

started” project requires only very few 1/Os.

Getting Started STEP 7 Lite A5E00293886-01
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Overview and installation

Installing
STEP 7 Lite

For the installation you need:

— the STEP 7 Lite CD containing the
installation instructions in
STEP7Lite\Disk1\Readme.WRl,

and

" Langue dinstallation: Frangais

- o — the corresponding license key (user
Idioma de instalacién: Espafiol . A
' Lingua di nstallazione: Italiann authorlzatlon).

SIEMENS

Cancel |

Insert the STEP 7 Lite CD.
The installation programm is started
automatically or via drive>:\setup.exe.

Follow the installation instructions.
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When prompted to do so, insert the
data carrier containing the license key.

Follow the on-screen instructions for
installing the license key.

Desktop after installation )—‘y Remove the data carrier before
restarting the computer.

After installation is completed, STEP 7
Lite will be displayed on the desktop
= and in the Start menu.
H=
=M 71U Any additional SIMATIC software you
install can be called via this SIMATIC
directory.

= o You can find the printable STEP 7 Lite
E— () Documentation .
[T) License Management ¥ g(?curf]entatlon under .
— ) Product noes imatic > Documentation.
Converting 55 Files
"2 Documents =i Setting the PG-PC Interface
. STEP 7 Lite
= Sethings - :

! Search

{P Professional

—( Transfer license keys

If no valid license key is installed for STEP 7 Lite,
a trial license key is used, which is supplied and
installed by default together with STEP 7 Lite.
However, STEP 7 Lite can only be used for 14
days with this license key. When STEP 7 Lite is
started the first time without a valid license key,
the trial license is activated.
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Overview and installation

—

B

STEP 7 Lite

3 H Autamation
v [T Product notes
[T STEP 7 Lite

Programs
. Documents
= Setkings
) Zearch

@ Help and Support

- XP Professional

User Interface for the
Automation License Manager

B automation License Manager

File Edit Lic
X :,@ = License Key mEZs ?

=1 ] Mv.CDmputer
= 3% Floppy (A
Wn2K_E (1)
Daten (D)

14
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To transfer the license key from one
computer to another, proceed as
follows:

Start the Automation License Manager.

Access the drive on which the license
key to be transferred is located.

Select the license key, and then select
the License Key > Transfer menu
command.

In the dialog that is then displayed, on
the target computer select the drive to
which you want to transfer the license
key.
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Starting and operating

Opening the sample project

How to open the sample
project in LAD

G
STEP 7 Lite STEP 7 Lite is installed on your
computer.

This chapter contains the most
. important information relating to the
» o Bl il user interface.

.':] License Management

p 0 odi e n Start STEP 7 Lite via Start menu or

§E STER7Lie {4 55 Converting S5 Files .
Gll] Setting the PG-PC Interface desktop icon.

. STEP 7 Lite

Programs

Dacuments

E Simatic
|

E}-‘ Sektings

- ssarch

XP Professional

@ Help and Suppork
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Open Project

%;l Mew Project |

™ Create from online CPU

STEP7 Lite

Last processed  File system IMe arsEard |

Search in:

= !

-8 s#EE

@ first_steps_fdb
@ first_steps_lad

e Go to the sample program directory

<Drive>:\Siemens\S7Lite
\Examples\English ...

@ first_steps_stl

e Select the LAD sample file.

first_steps_lad.k7p

Open the project file.

File: narne: | first_steps_lad

File bype: IProjects *.k7p

[

r Always open current project

Cpen as copy. | Qpen_l

Cancel

Open the project as a copy to avoid
overwriting the sample project supplied
by mistake.

The selected project is opened

=2 STEP 7 Lite - first_steps_lad
File Edit “iew Insett Options 'Window ﬂ:\p

The project window displays

| @ 0)v [ Wdidhide (& 5]  mm | oo

8 121 cantrol the CRU Crilne 2

I|] Hardware
@j Symbo
ﬁ Monito HiFy
M Cross-refi CLlCK
&4 Project de _J
ﬁ Proaram &
15 1 g Petrol A
1 1 R sesel A
7] DB: El
3 CLICK I e
{7} FC1iFan ]
{F OB1:Main_Progra g 71

SR N 2

"first_steps_lad”.

The left project window represents the
central navigation tool of STEP 7 Lite.
From here, you can open all STEP 7
Lite views via the project elements
"Hardware”, "Symbol table” etc.

23

Double-click on each elements. The
views are opened in the gray working
area, while the menu bar on top is
adapted to the respective view.

Double-click on the project elements to open all
STEP 7 Lite views one after the other. Close any
windows not required anymore in order to
maintain your overview.

Getting Started STEP 7 Lite A5E00293886-01



Menu bar*

Project window

Working area*

Online connection between PG and CPU

(now on “ON”)

Toolbar*

S1EP 7 Lite - firsl _steps_la
File Edt “iew |nsett Options

CPU control panel

‘Window Help

Libraries**

| 2 A e

I [2] Cortrol the CPU Online & ‘

Il] Hardware

@j Symbal table

L ﬁMonitorJ‘Modify

by J Cross-references

Ly g Project dacumentation

L 1% Program Q&

[ DB1:Petrol A

o DB2:Diesel |
DE3:5_Data |

N {} FE1:Engine |

\ { FFC1Fan |

a

{} OBL:Main_Program

!@ Online-CPL .-"

Integer fet.
Floating-point fct.,
Mave

Pragram contral
Shift/Ratate
Status bits
Tirners

(=3 word logic
Mulkiple instances

Data on the SPS
(for an online connection)

Data on the PG

Program elements

Project elements

LAD, FBD commands**

Status bar
(CPU currently on Stop)

Completed program elements

Getting Started STEP 7 Lite A5E00293886-01
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The user interface

The user interface is split into five
areas:

Project window
All project elements you require are
already created when you generate
a new project.

Libraries
The included blocks are found under
"Libraries”. LAD and FBD block
instructions are found under
"Commands”.

Working area
The views in which you can edit
your project can be opened here.

CPU operator panel
Represents the CPU front panel with
its displaying and operating ele-
ments. Lets you change operating
states.

Menu bar 2.5
Contains all menus available in
STEP 7 Lite — e.g. with opened
block, menu command View > LAD
for changing the programming
language.

Click on the expansion icon to show
or hide the CPU operator panel.
Click on the pin needle to lock or
unlock the view of the project
window and libraries. When
unlocked, you can increase or
reduce the size of the working area
by dragging it with the mouse
pointer towards the edge.

Getting Started STEP 7 Lite A5E00293886-01



Starting and operating

Project handling

What is a project?

The project data of a STEP 7 Lite
project includes all data of a
SIMATIC S7-300, C7 or of a
modular Distributed 1/O System ET
200X or ET 200S (stand-alone).

Projects serve the purpose of
saving all data acquired during the
creation of an automation solution in
a managed file system.

Getting Started STEP 7 Lite A5E00293886-01



-+ STEP 7 Lite - first_steps_lad Project handling
File Edit

| @ Alv [ diso [& N[ % mmH | o

I [2] Control the CPU Online %
SIEMENS
CPL 315

“iew Inzert Option: ‘window Help

Project elements are linked to the
following tasks:

Creating and saving a project

Hardware configuration, module
parameter assignment and hardware
error diagnostics

Specifying symbols for symbolic
programming

Running program tests, monitoring,
controlling and forcing addresses in the
CPU

Ill Hardware
Eij Symbol table

ﬁ, Monitor Modify
M Cross-references<e—i

e

Evaluation of the program structure

45 Project documentation <& and addresses used

£ Program -~
i~ DB1:Petrol b
(=] DB2:Diesel 2
[~ DB3:5_Data g

Individual arrangement of program
documentation

Using blocks to create an SPS user
program.

File handling

Save the project under its name and
file format ... .k7p.

STEP 7 Lite lets you open only one
instance of a .k7p file.

online connection between the PG and
CPU, you can use the CPU operator
panel to trigger motions in a plant, for example.

l Risk of accident — When there is an

Thus, never select "RUN” if you cannot entirely
exclude personal risk.
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Starting and operating

Calling help functions

~STEP 7 Lite - first_steps_lad - [Hardware] Windows Help
ll] File Edt “iew Insert Option: ‘Window Help
T T h.-. X [ se | You will find it easy to handle the
. STEP 7 Lite Help system if you have

Rack | rock1 | previously worked with Microsoft

Slat | Module p rOg rams.
— 1

CPU31S

B RL
"STOP" Button
Click this button o switch the CPU from RUN to 3TOP.

Do this, for example, to load an entire user prograrm with
hardware configuration.

Press F1:
The detailed basic help pops up.

2

3

4 | SM321 DI1A:
5 |5M 322 DO1
3]
7
g

Press Shift + F1:
Then, position the question mark
cursor on a button and click it to
open direct help on this button.

fou can then click the "RUN" button to restart the CPLL

rg Operating Modes and Mode Transitions

§ Project documentation

1¥ Program |
) DBLPetrol % T You can also chooge to access these
{5 DBz:Diesel g My — two help systems via Help in the menu
[ DB3:5_Data X HE T bar.
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ll] File Edit “iew Inset Option: ‘Window Help
= H Ll ol B | S X
|—:> Rack 0 l Rack 1 ] Ra
ga b Slot | Module
-
i g P 2 | CPU3LS
ol - 3
: T i 4 |5M321 DI16xDd
“witches the CPU to STOP mode, 2 5 |5M 322 DO16xD)
&
"STOP" Button 7
Click this button to switch the CPU from RUN T CLICK 8
Do thig, far example, to load an entire user pro s 4
hardware configuration. VB 11 i?
You can then click the "RUN" button to restart the-sfi
=
I T =
—( The online help is called.
Y
E? Help on STEP 7 Lite
a1 & = fa = B
Hide Back Formard Home Print. Gloszary Project Wwindow

Contents ]Index } §aarch|

+ e Introcucing the Product and Installing the Sof
= 0 Basics of Designing a Program

+ e Startup and Operation

+ 0 Setting Up and Editing the Project

+ e Configuring the Harcvware

% & Programming Blocks

+ € Establishing an Gnline Connection and Makin
% @ Import, Export, Save As

+ e Dovvnloadding ta the CPU and Uploading to the
= 0 Debugging

+ e Diagnostics

% @ Printing Project Documentation

+ e Tipz and Tricks

= |1 Appendix
= I[]] Operating Mades
il tin

[2] STOP Made:
|2] STARTUP Mode
[2] RUN Moadz
2] HOLD Mode
+ € Memory Areas of ST CPUs
+ % Data Types and Parameter Types
+ Q Sample Programs
+ € Accessing Process and 10 Data Areas
+ € Sefting the Operating Behavior
= @ Caling Reference Helps (LAD, FED, STL, Blo

Operating Modes and Mode Transitions
Operating Modes

Operating modes describe the behavior of the CPU at a particular p
CPUs is useful when programrming the startup, testing the controlle

CPUs can adopt the following operating modes
« STOP

« STARTUP

o RUN

« HOLD

In STOP mode, the CPU checks whether all the configured module:
actually exist and sets the I/Os to a predefined initial status. The u

In STARTUP mode, a distinction is made between the startup type

In & warm restart, program processing starts at the beginning of
systern data and user address areas (the non-retentive timers, o

In & cold restart, the process-image input table is read in and the)
starting at the first command in OB (also applies to warm restal

o Any data blocks created by SFC in the work memory are delef
preset value from the load memary

o The process image and all tirmers, counters, and bit mermory
assigned as retentive or not.

In RUMN mode, the CPU executes the user program, updates the in

The three Help sections

Quick help

Without clicking, position the cursor
on the STOP button, for example.

A quick help on the button is
displayed when you position the cur-
sor on the button and leave it there
for a moment.

Direct help

Click on the small arrows to open
direct help as well.

Basic help

Click on the link. Detailed basic help
on the selected topic pops up in a
separate window.

Note:

The different link icons identify the
type of help called in the basic help.
Leaf = Background information

List = Handling instructions

2.9
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2.10

Starting and operating

“ . STEP 7 Lite - first_steps_lad - [Hardware]
ll] File Edit View Insert Window Help

& 3 | W s o

E [2] Contral the CPU Online

Settings... Clrl+Al+E

Set PG/PC interface. ..

Manage Multlingual Texts
Optional package

-

Rack O ]Rackl ]

Slat | Module
1
2 |CPU31S
3

CLICK

SuicK]

7 Datei Beabelen Ansicht Enfigen Test Ehas Fenster Hile

A IR " Lvs

= Bibliothe

Adresse Dreklaration MNare: Twp Anfangswert Kommentar
sl cunch.on oL Fause oo aschten
ol e of o — oo suechaten
0.2 in Failure. BOOL FALSE Motor skirung, Fihrt zum Ausschalken
24 in Actual_Speed INT o tatséchliche Motordrehzahl

% s hstawerk
) Bitverknipfung
[ verglsicher

s Unnwandler

1] Zaler

(D8] DB-AuFrUF

155 erste_schritte_kap
W) Hardware Q

[sPs |

“mutomartik
Ein~

il Beobachtenstevern

J Querverweiss

zu Meldungen

19 [=] X

ibeiten Lesezsichen Optioren 2

Irhah_ [ Indes | Zuiiek [Dneken] Glossar |

Hilfe zur Meldung 34:4467

Beschreibung: ﬂ
Der Datentyp lhres Formalparameters passt nicht zum Aktualparanfeter. Bitte Uberprifen Sie

den Datentyp hres in der eigenen oder in der

Den enwarteten Datentyp des Formalparameters kennen Sie durch
Bausteines ersehen

Zugerufenen

Behebung:

Bitte gleichen Sie die Datentypen einander an. Bei lokalen Aktualparameter, symbolischen
NB-Zueriffen 1nd in der Simhaltahelle definierten Mneranden miissen diese Natentunen

F N 003: AkEusldatetyp BOOL paft richt 2u Formalem Typ SSTIM

(&1 Springe
[z1) Festpurki-Fke.
28] Gletpurki-FLr.
(2 Verschieben
0] Programmsteueru
231 Schisben/Rotieren|
0] Statusbits
(o) zeten

] s_meus

g

7 ez

T oz

il

s

< -
2~ CLIC
< (5

< (5.

wile -

K]

< ~(sa)
# (3 Wortverknipfullg
B Mulinstanzen

=

F M 003: Aktualdatentyp BOOL pafit nicht zu formalem Typ SSTIVE des Formalpara... ¥

Bausteinedicor /{5 Eigenschaften

 Eeiehe  EIETTYY

+—( The reference help opens.

ife zu KOP.

Datei Bearbeiten Lesezeichen (ptionen 2
Inhalt [ Index [ Zuiick | Dueken | <« [ > [ Hite 2uSTEP 7 Lite] Glossar |
S_IMPULS Zeitals Impuls parametrieren und starten Hilfethemen: Hilfe zu KOP
nhat | index | Suchen |
T
SpuLsE s mpuLs Klken Sie auf ci Thema und dern aul "
s q 3 qQ anderes Register.
v Bl i puaL|
Bco ko oez & Festpunkt-Funkiionen
@ GletpurktFurklionen
@ Verschishen
Faramter Farameter [ spaiher Beschreibung P-4
Enizeh Detion beraieh Programmsteuerng
Too T TMER T imer der Zai, fezahi der Zeieen @ SchisbendRtieren
izt von der CU bringa @ stausbis
s s B00L EAMLD  Stnsingang @ zei
~ L4 SThE EAMLD  Sbrdngesteltar Zetuert e
R R Bo0L EAMLD  Ricksasingang Zatoperatonen Dbersicht
o ouaL worD EAMLD  Aueler Zetuan, bvirodien
Bco ez woRD ELAMLD  Aueler Zetuar, BCOFoma
0 o Bo0L EAMLD St dirZat

Beispiel 1: Steuern eines Forderbandes

Gegenstand auf dem Band dessen Ende erreicht

Hife 2u STEP 7 Lie

Hilfethemen: Hilie zu KOP

D3 0gense Bl st e Fordrbane, s HsknSch i Gany gesstz werdn K. A Anfeng s s 620 | [k | ngay | Suchen|
befinden sich ebenals zwei Druckscheter, 53 fix START und S4 fr STOP. Das Banl ke von beiden Enden s ¢

Glossar

Klicken Sie auf ein Buch und dann auf'0f

T
(V] o)

@ Frogammsteuenng
@ schichen/Rotieren
@ stachic
@ zeiten
@ wotverkniipfung
{0 Programmierbeispicle:
[ Proganmieibeispicls Ubersicht
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Further help

Help on menu commands
Press SHIFT + F1 to open a pull-
down menu. Click on a menu
command. The help on this com-
mand is displayed.

Help on error messages
You can also call help on error
messages which are displayed in
the status bar. Right-click on the
error message to call Help.

Reference help
Press SHIFT + F1 and then click on
S_IMPULS, for example.
The reference help pops up in a
separate window.

The reference help provides help on
the selected instruction or block.

Here you can also call programming
samples, for example.

Close the copy of the sample project
after you have familiarized yourself with
the operation of STEP 7 Lite.



Implementing
the task




Implementing the task

Task — Motor bench

Light barriers Using our "Motor bench” example, we
lead to OFF are going to show you the most impor-
tant steps to implementing this task in
Operator station an automation solution.

Diesel engine with
ON/OFF switch and

Petrol engine with

ON/OFF switch and tachometer Task
tachometer

A controller for a motor bench is to be
developed. In the first step, we will only
develop the global circuit for the actual
testing circuits:

Fan with Fan with

ON/OFF switch ON/OFF switch 1. A petrol engine and a Diesel

engine on a bench is to be switched
on and off individually.

Getting Started STEP 7 Lite ASE00293886-01



Network 4 : Switching on the Petral Engine

Call for the fumctiom block FEL (" Eng1ge ") with the data far a

petrol engine (data block 'Patral®

"Petrol"

"Switch_On_PE"—
" Swtch_0ff_PE"—
"PE_Failure"—

"PE_Actual _Spesd”

TErgine”

PRE_On"

Network 5: Switching on the Oiese] Engine

dizsal engine (data "Disss

<all for the function block FE1 " Eng1ﬂe ") with the data far a
DEZ)

"Diesel"

"Switch_On_DE"—
" Swtch_0ff_DE"—
"DE_Failure"—

"DE_Actual _speed”

TErgine”

'PE_Preset_Spesd Reached

hoe_on

FDE_F reset_Speed_Reached

2. Alight barrier on each engine
secures the area of hazard. This
barrier triggers an EMERGENCY-
OFF circuit, independent of the
sample program.

3. An electrically driven fan is also
switched on or off with the engine.

4. The fan’s off delay is four seconds.

5. The operator will receive a signal
indicating that the engines have
reached their speed setpoint:

Petrol engine = 1.500 U/min
Diesel engine = 1.200 U/min

Solution

Here the solution beforehand: OB1 in
the sample programs contains the
signal "Preset_Speed_Reached”,
realized in

— Network 4 for the Petrol engine.
and in
— Network 5 for the Diesel engine.

Further information is found in Chapter
7, section "Programming block calls”.

You could now use the

"Preset_Speed_Reached” signal to

initiate a testing process, e.g.:

— Start of a exhaust gas comparison
test

— Start of a speed stability measure-
ment.
However, this is not part of our
sample program.
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Implementing the task

Splitting the process

Defining function range

Specifying safety requirements

Specifying operating and display elements

Determining Inputs/Outputs

To create a program,
see subsequent chapter

Getting Started STEP 7 Lite ASE00293886-01

Split the process before you start
programming.

A basic procedure you can use in any
configuration is shown above.

Every step can be split into
subsections.

Higher granularity of the split process
considerably simplifies the user
program structure.



Function range

Related devices

Function range A

Function range B

= Petrol engine
= Tachometer
= Fan

= Diesel engine
= Tachometer
= Fan

Metwork 4 : switching on the Petrol Engine

Call for the function bBlack FBL Eng1ne ") with the data for a
petrol engine (data block "Patrol” DBL).

"Petrol"
TErgine”

Hetwork 5: Seritching on the

diese] engine (data "Diesel"

" Switch_on_FE"—
"Ewitch_OFf_FE"—
"FE_Failure'™

e on®
| 2PE_Freset_Speed Reached

"PE_Actual _Speed"

call for the function block FBl c Engine") with the data for a
E2)

=}

Diese] Engine

“Dissel”
TErgine”

" Switch_on_DE"—
"ewitch_Off_DE"—

‘ "0OE_Failurs")

oo on®
| -DE_Freset_speed Reached

"DE_Actual _Speed"

[=|

SIEMENS 05
53] first_steps_lad

Filtdr Show all

~ Edit Filter...

‘ Address | Data Typel Comment

Display addresses without symbols

Stallus | Symbol

Ill Hatdware
Symbol table
ﬁ ManitariModify
2 Cross-references
§ Project documentation
43 Program
[5] DB1:Petral
[5] DB2:Diesel
|7 DB3:S Data
{F FBL:Engine
{ FFC1:Fan
{F ©B1:Main_Program

-

Main_Program 0B 1 CB1 This block conkains the user program
Manual_on 10,6 BOOL For the memory function (switch of F)
PE_Actusl Speed MW 2 INT Actusl speed For petral engine

PE_Failure 11.2 BOOL Petral engine Failure

PE Fan On 05,2 BOCL ‘ommand for switching on petrol engine fan
PE_Follow_oOn TL TIMER Fallow-on time For petral engine Fan

={(_EE_OD) 250 EQOL JCommand for switching on petrol engine
Display "Petrol engine preset speed reached”

Petral DB 1 FB1 Data for petrol engine
Red_Light Q4.1 BOOL Coil of the parallel connection
5_Data DE3 DE3 Shared data black
Switch_OFf_DE 115 BOOL Switch off diesel engine

O TT.1 BOOL - Y5witch off petrol sngine
Switch_On_DE 114 BOOL Switch on diesel engine
Switch_On_PE 11,0 BOOL Y5witch on petral engine

(==, Online-CPLI

S4s-] | DISCOMNECTED

Describing function areas:

— Split the process into related
groups.

— Specify the elements controlling this
area.

— Specify electrical, mechanical and
logical 1/Os for all tasks.

— Specify locks and dependencies
between the tasks.

Specifying safety requirements:

In our sample this is the emergency off
circuit. In the real world, however,
programming this task is much more
complex.

Defining operator and display elements:

Every process requires an operator and
monitoring system that enables human
control of the process.

Specifying 1/Os:
Even for our small sample project, you
need three physical Inputs and Outputs

for the petrol engine PE

The symbol table in Chapter 5 offers
you a good overview of all I/Os.

Getting Started STEP 7 Lite A5E00293886-01

3.5



Getting Started STEP 7 Lite ASE00293886-01

We invite newcomers to participate in the
SIEMENS training courses. Here, they are shown
practical examples on how to automate
processes using a SIMATIC system.



Module
configuration




Module configuration

What happens during
configuration?

During hardware configuration you
develop an image of the PLC station on
your programming device. You can
Hardware  Proiect] copy this configuration to other STEP 7
Lite projects and, if required, modify
and download it to other existing sta-
tions. During the PLC startup routine,

[ oo | eEs? v ohint | k2

Rack 0 | Rack 1 | Rackz | Rack3 |

Slat | Module Order number 1 addh
PS5 307 24 £E57 307-15A00-0AAD the CPU compares the default con-
CPUSIS 5857 315-1AF03-0AB0 . i K . i
R e SM 321 DI 16xDC 24 6E57 321-1BHO0-0AAD 0., 1 f|gurat|0n Created in STEP 7 the Wlth
LA s e T S O SM322D0 16xDe 244/0.5 |6ES7 322-1BHOD-0AAD the actual Configuration of the SyStem
This way any existing errors can then
= bl e —— R be detected and reported immediately.
24y MonitorfModify
I Cross-references ;
ﬁjt N g e moEematen Ode__,__a The hardware element in your project
i T window shows a graphic representation
(0 pe2iDfsel = S 322 DO 16xAC 120V/0.54 5] 1 6657 322- 1EHO1-0AA .
L paces 2 v o of a rack. Here, specify all modules you
FB1:Erfine 22-1BHOL . . :
L e % — e have integrated in the PLC station.
1} 0B1:Mpin_Program 51 6 7 8 91011 S 322 DO 32%AC L20V/ 1A 6ES7 322-1ELO0-
5M 322 DO 324D 249/0.54 5E57 322-16L00-
: T — At a later point, you are going to edit
Prrtriiciors SRR

SM 322 DO BxAC 120/230W 1A BEST 322-1FFE1-|
SM 322 DO BxDC 2441054 BEST 322-B6FE0-

the user program in the program
element for precisely this hardware
configuration.
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Hardware configuration
overview

Create your hardware configuration
within a project. Projects and programs
always belong together, since you ...

Opening the project

... also assign the I/O address areas in
your hardware configuration. And, you
subsequently specify these addresses
in your program.

Configuring

You can modify some of the modules
for the Siemens factory settings.
However, this is not required in most
cases.

Parameterizing

You can then you perform a con-
sistency check for your hardware
configuration and save your entries.

Testing and saving

: Download the hardware configuration

Loading to CPU from your PG to the CPU.

So that,

- the CPU can recognize all existing
modules and their addresses,

- module parameters can be
enabled.
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Module configuration

Creating a new project

0 In this chapter you are going to create

Your “Getting Started” project must have
your existing hardware configuration and
not the one in our samples.

Getting Started STEP 7 Lite ASE00293886-01

a new "Getting Started” project, shown
here at top entry level.

In the subsequent chapters you will
continue to develop this project.

You can follow the sample projects also installed
when configuring your hardware. The sample
projects are under :
Drive:\Siemens\S7Lite\Examples\English...

The hardware configuration is the same in all
three sample projects.



How to create a new project

: STEP 7 Lite is opened . . .
H ‘ Start STEP 7 Lite with a double-click.
CLICKI
© STEP 7 Lite
File Edt View Inset Options Window Helg .
| W [k [ v st e Open a new project.

3 121 Control the CPU Onine ¥

Save the project as

& "Getting Started”
=l
5N Edit Yiew Insk S
New 2 @
[=> Dpen Project... E %
Close Project @

° Click on the pin needle to hide the

48 Conect Onl libraries.
dlin Downioad Fi R rU Rename:  [Frst_steps_fdb

s Upload to Progr
Trarwter Files CLICK etpei  [orojects (*.k7p) =]

™ abiays open current project Open as copy. | Qpen I Cancel |

Export

Impoit....

e If you want to use one of our
configurations as a guideline, also

open one of the included sample
After double-clicking hardware projects in a second instance of

STEP 7 Lite.

=5 STEP 7 Lite - Getting Started - [Hardware - Project]

|| Fie Edt View lInset Opiions ‘indow Help

|l [ dd (Sa | Lmm oo | e

v hibt | K2

Rack0 | kac 1| rackz | Rack
Sot | Hoduke Crder uber Taddress | @ scdhess | Conment

e Double-click on Hardware.
The hardware configuration windows
opens in the working area.

X crosseet I.gt wpten

&5 Project docur
17 Program
L oBLiCyCL_

SMALFO
Ei

Tn order ko sdd modlles, select a modue B

category, choose the desired mode, and

= dragi tathe desived slot in the rack or ENEN®
o b parameters. the table, =

Special 300
Compatbh

You can copy hardware configurations from one
project to another. For example, if you want to
continue immediately with Chapter open one of
the included sample projects and copy the Hard-
ware element to your "Getting Started” project
(see Step 5).
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Module configuration

Working in the hardware
configuration view

Graphical view of
hardware configuration Configuration table Hardware catalog

“-_-. STEP 7 Lite - Getting Started - [Hardware - Project] O]

ll] File Edit “iew |nsett Options ‘window Help =18 X
= g, m | S Al BEST - i Bt k2

Hardware - Project

Rack0 | Rack 1 | Rack2 | Rack 3
Slot | Module Order number laddress | & address | Comment
— 1
z
3
4
5
:
%) Getting Started *'] 5
h - f]
&2 Symbol table I i 4 s e 7s 9011 i?
ﬁ Monitor/Modify
2 Cross-references l,l_ E—
§ Project documentation i
gprogram 5] J— i
LHOBLCYOLERC 24 T sacerzomu =
L SIEMENS 5
0 SM Al
eS| MAIGIST seUU SM AG
4.6 M ATJO
172345678 9011 SM DI
In order to add modules, select a module SM DO
tegary, choose the desired madule, and
S Gragit ko the desked siot Inthe racker SM DI
| o the table, c7
Sperial 300
Compatible
MOnline-CPU 2 _'; Hardware Compagisan EL Hardware Canfiguration b Hardware Diagrpstics
Parameterizin
Hardware modules 9 Choose
element SIMATIC system
Differential icons .
Overview
After opening the hardware element
Display differences between SPS station and CPU with a double-click in your project
(only when an online connection to CPU exists) window, the "Hardware” view is shown
at the right side in the working area.
Select the modules of your PLC station

Display technical problems on modules from the hardware catalog here.
(only when an online connection to CPU exists)
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Hardware - Project

How to configure the hardware

The following modules are stored in the
sample programs:

1 Power Supply = Power supply
module

CPU = SPS module

Digital Input = Digit input module
Digital Output = Digital output
module

A WN

Order numbers are imprinted on the
module front panels.

Configure your module as described
below.

Rack 0 | Rack 1 | Rack2 | Rack3 |

Slat | Module Order number Iaddress | Q address  Comment
1 Ps 307 28 EEST 307-1500-04A0
2

3
4

Go to CPU 315 and click on the "+”

3l

QOOEO! OC
N 1011
20 |

QLOOE O
T 1011
o .

e

0

Z8|e e ||

1
1

0 Click on CPU.

icon to view all earlier versions of
CPU 315.

v Disglay module information e |
Module Gl ey b3 |
] FEST 315-1AF03-0AB0 1.2 - - CPU
TWark memory 48 KB; 0.3 ms/1000 instructions; MPT connection; ™
multi-tier configuration up to 32 modules; 57 Communication
(Inadable FEsiFCs); Firmware Y1.2 5M AT
H6EST 315-1AF0Z-DAED
45 KB work memory; 0.3 ms{L000 instructions; MPT connection; SM A CLICK
multi-tier configuration up to 32 modules SM ALfO
M DI
000 instructions; MPT connection; SM DO
up to 32 modules ETrT e D .
rag the CPU to the rack using a drag-
B0
1000 et s cernectons for | (oo and-drop. A lock sign indicates slots
CLICK Campatible . f .
& dee: l - which are not permitted according to
(<P Wk memary 64 KB; 0.3 ms/1000 instructions; MPT+ DF connection th | |
315-20P (DP master or DP slave); multi-tier configuration up to 32 modulss,
expanded environmental conditions, send and receive capability F... es Ot rules.

—( Another window opens )J

Proceed in the same way with all
modules.

We shall continue with Chapter
"Module parameter assignment”’ on
Page |4.12. Refer to the next page for
more details.

Of course, if you later want to download the
hardware configuration to your CPU you must
configure your hardware, and not necessarily the
one in our sample project.
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4.7



Module configuration

Input . Output
module X module
Byte 4

Output
module module
Byte 1 Byte 5

Absolute address: Q 4.1

~—

Output Byte4 Bit1

Configuration results

Working from left to right, insert the

....... Hodde Order number Taddipss | G address power Supply mOdUIe, CPU, input
—Hasas —|ssraeintiog module, output module.
— s S ecaom arimers (15 )
mg 2 ® e Modules must be inserted without
L .

4.8 e leaving empty slots between them.
1) Moritar/Modi ! . .
g Otherwise, they cannot be supplied
48 Project documeniation v Display module information . .

Sy @ Modie | ordet et with power via backplane bus.
Drosucvee 4 132200 s o bo 16 A< 12071054, arsi, s -
120%/0.54
o0 BTS00 apre o Exception in STEP 7 Lite: Slot 3 is
;Sé?n(?m ermionmenial conditions » oreupna

reserved for the interface module (IM)

K| 6ES7 322-1BHOL-0AA0 —

Pl S B DOLS 0C 21D, crouona you can use to connect racks stacked
[T ke I on top. If modules are inserted only in
o the lowest rack, you can leave a space
L ] in the configuration.

The address specification bytes have
_e been set automatically in the I/O
address columns of the configuration
table. They are a major component of
address specification for programming.
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£ 5 STEP 7 Lite - Getting Started - [Hardware -

Project]

Wy Fie Edt View Inset Opfions \Window Help

EAC I

B 121 controi the CPU Onine

2o Moritor gl
M Crossrefences
(58 Project
¥ Progra
T} oB1 veL_Exc

S| dREX [

Hardware -

Project

34956 78 31011

i 1
3456 7 881011 T

BEST

~ #i tt n?

Slat | Module
1 PS5 307 24
2 CPU31S
3

S

Module

4 5M 321 DI 16xDC 24V
— 5 5M322 DO 16xDC 24%/0.54

v D’p\az module i

Rack0 | Rack 1 | Rackz | Rack3 |

Order number Laddress | Q ad
6ES7 307-1BA00-0AAD

6EST 315-1AF01-0AB0

6ES7 321-1BHO0-0AAD (0., 1
6ES7 322-1BHO0-0ARD ™

‘ormation

Order number

M2z po B HBEST 322-1EHD1-0AAD

51322 D0

Eiexac Diglal output module DO16 AC 120%/0,54, grouping 4, Si.
120vi0.54
[ dfes7 322- 18Ha1-04A0
SM 322 DO
Eie00 Diglal output module DO16 DC 244/0.54, grouping 6, extende
= nsa | smjpermental candions
fES7 322-BHO1-0AA0
Dusr gutput madule DO DC 24/0.54. arouping 8
1GEST 322-IBHO0-0AAD
Digital [leout module DO16 DC 244/0.54, grouping 8, not for
configi with active bus submodules
HIEES) 3.

e

Digital outs CLICK 2di/2n, 120v/20, 230v/28, )

Two projects are opened )J

C,STEP Lite - Gelting Started - [Hardware - Project]
i View Incet Options Window Help

B s gy

Hardware - Project

BEST

- #i At

N2

Rack0 | Rack 1| Rack | Rack3 |

a3l Slot | Module Order number Laddress | Q addvess | Comment
i — 1
! 2
| ! 3
1 3d4seragmn ;
6

2

2L 7
i 9
= 10
1 3456 7E9mn I

e
28 Monitor ModFy
3 Crossreferences

8 Projiect documentation
A Program

3 oBticveL_Evc

45678 91011

45676851011

‘ CLICK I

I ordr to a0d moduies, Selett @ madue
category, choose the desired module, and

= drag it to the desed slot In the rack or
the table =3
Special 30
Compaticl

SIEMENS 0

Tips — Inserting modules

Improve your screen overview by hiding
module information, e.g. if you want
to perform a directed search for order
numbers.

Insert modules, for example, by right-
clicking the module to open the pop-up
menu and select Insert module.

You can insert new modules between
two existing modules. The modules are
shifted to available slots on the right
side.

Using the Shift key, you can highlight
any number of modules in the rack and
then copy them or move them by a
drag-and-drop operation.

Open another project in a second
instance of STEP 7 Lite. Then, for
example, drag the complete hardware
configuration from one project to
another by a drag-and-drop operation.

To delete a module, right-click on the
module to open the context-sensitive
menu and select delete.

Feel free to try out all functions you have used in
other Windows applications.

We have implemented many Windows functions
in STEP 7 Lite, e.g. pop-up menus, drag-and-
drop operation, working with shortcut key etc.
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4.10

Module configuration

VW findow  HElD
= &l | # wo e

EEST

Slak
1

Madule

Rack0 I Rack 1 I Rack 2 1 Rack 3 ]

2 |C7 624(F

3 |7 IM 360

4 | C7 DIfO16x244 /0,54 a
5 | C7 AL4/AO4[ULY

6 |SM 321 DI GxAC 120/230%

7

- hint | K2

Order number

6EST 624-1DE01-0AE3

Iaddress | )

2000
Z72.,
BEST 321-1FFG1-04A1

1 a
. 2872

)

Module:

==

= 3M 322 Do
=l axUc 60

5M 322 [
ﬂ 16xAC
=l120/230v)
A

5M 322 D
El16xAc
120v/0.5

have inserted a €7 module and 3 sta
here is no Receive module IMR/IMIR in rack 3.
here is no module in slok 5 in the rark 3.

E Rack 3, Slat 3:
E Rack 3, Slat 5:

v Display module infarmation

Craer number
M 6EST 322-5HFO0-0ABD
Digital output madule DOSxREL

HEEST 322-1FHOO-0AAD
Digital output module DO16 AC 120%/2304114, gr
1

M GEST 322-1EHD1-0AAD
Digital output module DO16 AC 120%/0,54, groupi

ping &

g 4, Si,

M 6EST 322-1BHB81-0AA0

Digital outout module D016 DC 244054, arounind/S, extery

nod lle simultaneousky in one rack, Simultanec both modules

U have inserted a C7 module and

m

Reck 0, Slot &:

standar. § %
=

% Hardware Comparison

B Hardware Configuration

Abs

fo [STORIN

N

CLICK I
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Example of a maximum
configuration

For demonstration purposes we have
created a large configuration with some
errors.

Call the troubleshooting routine via:
Options > Check Consistency.

An existing configuration error is
displayed in this view.

Left-click on the expansion icon to
display all errors.

Existing errors:

An interface module (IM) is missing in
Rack 3. As a result, there is no connec-
tion to Rack 3. Racks 1 and 2 are
equipped with interface modules.

Free slots are not allowed.

This is a C7 compact system (highligh-
ted in yellow background color in the
configuration table). The module on the
right side is incompatible.

After you have eliminated the errors,
perform another consistency check.

And otherwise:

STEP 7 Lite allows only one CPU per
project. The CPU is always inserted in
Rack 0. The top slots are not used.

Please note how the address areas are
incremented in the configuration table.



Online Help: F1

— Under Content > Configuring the hardware >
Configuring modules in the Help on STEP 7
Lite you can find global configuration rules.

— Under Index > Slot rules, you can find
the most important rules on insertion.

Browsing the hardware catalog with MLFB

The MLFB number represents the Siemens order
number.

If you know the MLFB number of a module you
want to look up in the selected hardware catalog,
you can enter this MLFB via "Find text” dialog box
in the toolbar. Then, press Return to display the
module.

Getting Started STEP 7 Lite A5E00293886-01



Module configuration

Module parameter assignment

0010
1 1‘| 10

¢

SIEMENG

What is parameter
assignment?

You can customize the operating
characteristics of some of the analog
and digital modules, as well as those of
the CPU: we refer to this as "Parameter
assignment”.

Examples of parameter assignment to
a CPU:

L o — You can interrupt the CPU’s pro-
gram cycle via watchdog interrupt.

e — Specify a name for the CPU. In this
case, it is "Mozart”.

a — You can also password protect your
CPU against MPI read/write access.

Getting Started STEP 7 Lite ASE00293886-01



3

RackO | Rack 1 | Reckz | Rack3 |

Slot Module Order number laddress  Q address  Comment

Assign parameters to CPU 315

| |P5307 28 6ES7 307-1BA00-04A0

— CPUEIS 6ES7 315-1AF01-0ABD

+ | 5M 321 DI 16xDC 244 6ES7 32L-1BHD0-0AA0 0.1

Highlight CPU 315. Click on

103458 780911011

the module parameters button.

L General

+ Processing Module Parameters HE IZ

eneral

Startup

Cycle

Clack memory
Retentive memory
Cydlic interrupts

Catalog information

Shart designation: CPU31S

Time-of-day interrL
Interface: MPT

1723456786911

Wodule parameters,

CLICK |

Order No.: 6ES7 315-1AF01-0ABD 1

48 KB work memory; 0.3 ms/1000 instructions; MFT - |
connectian; multi-tier configuration up te 32 medules

System diagnostics
Clock Project information
Rack: o

Slot: 2z

Mame:

Camment;

Startup

Menitoring time for

i In the Processing module parameters
3 dialog, enter "Mozart” in the Name box.
ﬂ_o
g Confirm your entries with OK.

= The window is closed.

ess F1 to get help.

A P Hardware Comparison j Pl Hardware Co

‘‘‘‘‘ / ) Hardware Diagno:

|

All basic parameters are factory set and match
almost any standard functions.

If anything goes wrong after you have made
changes — do not worry — the hardware catalog
still contains the basic settings for all modules.

Online Help: F1
CPU parameters are often related to organization
blocks.

In the Index under Cyclic interrupt, you can

therefore find the description of Organization
blocks for cyclic interrupts (OB30 to OB38).

Getting Started STEP 7 Lite A5E00293886-01
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Module configuration

Saving configuration data

=4 STEP 7 Lite - Getting Started - [Hardware - Project]

Settings...
Set PG/PC Interface

ClilAIE | eEs7 v #i okt | K2

Manage Multiingual Texts

Dptional Packages

CPU Operating Mode RUN
% | » CPU Operating Mode 5TOP
Clear / Reset

Module [nformation...

CPU Settings. ..

Sj Getting Started
ll] Hardware
= Symbol kable
ﬁ Manitar /Madify BRewie...

(4 Ensure Program Consi:
Set Block Bratection:

CLICK | "

3
v RackD | Rack 1 | Rack 2 | Rack3 |
Slot | Madule Order nurmb
1 |P5307 24 BEST 307-1H
2 |CPU31S BEST 315-14
3
4 |5M 321 DI 16xDC 24 BEST 321-1H
Clis i 5 |5M 322 DO 16xDC 24%/0.54 | 6EST 322-1H
]
7
9
10

2 Cross-references Compare Blocks
& Project documentation !

|

!

|

[ v Display module infarmation
R
R
I

1 Program ] Module: Order number
SM 322 Do M 6EST 322-1FHO0-0AAD
OBL:CYCL_EXC
O - A 1 345878 8100 P e Digital output module DO16 AC
12023001
A
| 6EST 322-1EHO1-0AA0
SM 322 DO
16%AC Digital oukput module DO16 AC
- 120W/0.54
1z 3 6 7 8 9 1011

oM 322 D0 ET] I.EvEIST 322-IEHJ81‘-DAAD

continues without errors )J

Getting Started STEP 7 Lite ASE00293886-01

How to check configuration
data

Before you save your configuration, you
should always perform a consistency
check.

Call menu item Options > Check
consistency.

This is to check whether your
configuration data can be generated
using your entries.

Confirm the message "The
configuration is error-free.” with OK.



. 5TEP 7 Lite - Getting Started - [Hardware - Project]

oy Fie [ view lneent Qptions window Help

s

Rack0 IRaEkl ] Ra(kz} Ra[kS]

Slot | Module Order number
) 1P5 307 24 EES7 307-1BA00-0AA0
L CLICK ] TP
| LG K Delete — 3
g 4 SM 321 DI 16xDC 24
S GO

 Seleotal Ctisdh :

%) Getti Unda Selection B

[ T — 3

— Find/Replace Ctr+F 0
Sy

GoTo 11
2 Me
X o

38 Project documentation v Display module information
1¥ Program [+'] Madule Order number
CEEEL | SM322D0 | HEES7 322-1FHOD-0AAD
o - 4 g Digital output module DO16 AC 120V/230W
=l 1200230071
A

B 16xaC

E|16xDC

HBEST 322-1EH0L-0AA0

5M 322 DO
Digital output module DO16 AC 120W/0,54,

1200/0.54
5M 322 DO & 8 8ES7 322-16HG1-0AA0

zqwjn.5a | Srvironments condtions

Digital output module DO16 DC 24%/0.54, of

How to save configuration data

Select File > Save, or click on the disk
icon in the tool bar.

This does not only save your hardware
configuration, but rather all project
elements.

When you select the menu command
Edit > Apply, your configuration data
(always the content of the active
window) is saved to a temporary file.
This file saving method is recommended
if you intend you to undo modifications
later.

After only applying data, you are
prompted to save your changes when
you close the project.

4.15
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Module configuration

Downloading hardware
* configuration data to the

W ocosv

~3STEP 7 Lite - Getting Started - [Hardware - Project]
ll] Eile Edt iew Inset Options ‘window Help

== R T P T R S =Y

O L= - hiont | k7

Rack 0 IRackl I Rack 2 I Rack 3 I

Slot | Module Crder number
1P5307 28 ES? 307-1BADD-DAAQ
z|cPUals 6ES7 315-1AF01-DABD
3
4|5M 321 DI 16xDC 24V 6ES7 321-1BHO0-0AAQ

A6 TS o oM 32700 16xDC 24W[05A | 6ES? 322-1BHI-OAAD
= « &
CLICK | ;
&
[ AHardviare a
10
&3] Symbol table T4 s e 7T e 90101 i
ﬁ Monitor fMadify
2 Cross-references 1
5B Project documentation ¥ Display moduls information
4# Program o] Module Order number
Croucraexe |4 T T HI6E57 322-1EH01-0AAD n
162AC
1204[0.54
[] &I 6E57 322-16HE1-04A0
f';'xgzcz PO T oigital autput mode CO16 DE 24v/0.58,
sewjuss | environmental conditions
—
HBES7 322-16H01-0AAD
Digital output module DO16 DC 240,548,
-
[oolile parameters | =
Ready for download )J

Getting Started STEP 7 Lite ASE00293886-01

How to prepare the download

With this download you transfer all
configuration data to the CPU.

Note that you must first establish an
"Online connection” between the CPU
and the PG. Details on this topic are
found in Chapter 10!

"Connect Online” essentials:

After you have connected the cables
and performed a CPU memory reset,
click on Connect Online.

In the CPU operator panel, set the CPU
to STOP mode. The footer displays a
red STOP icon.



etting Started - [Hardware - Project]

R X | oo | EESE

o oy ot | k2

Rack0 | Rack 1 | Rack2 | Rack3 |
3 Slak | Moduls Order number
1/Ps 307 28 6E57 307-1BAD0-DAAD
2 |CPU 315 BES7 315-1AFD1-0AB0
3
< |SM 321 DI 162DC 24v 6ES7 321-1BHO0-DAA0
1 3456 78 91011
5 5M 322 DO 16xDC 24¥/0.54 | 6ES7 322-1BHO0-0AAD
3
2
- 7
i | &
El
10
Lppl 45 6 7 8 91011 m
’ Print
& Prop Display module information
o Ploadlo Progiar g Devics [ Module Crder number
e Ensvre Program C K Sgtency

SM322D... | Al6ES? 322-5HFO0-0ABO

SM322D... | KISEST 322-1FHO0-0AAD
e CLICKJ SM 322 ... [E] 4 6ES7 372-1EHD1-0AR0
g S 322 0. [ A 6EST 322-18HB1-0AA0
Gy LI6ES7 522-1BH01-0AAD
Patte HI6EST 322-1BHD0-0AAD
= St 322 0. [£] 41 6ES7 322-1HHO1-0AA0
Fename #5678 95101 SM322D... | M 6EST 522-1ELO0-0AAD
Dielete SM322D... | AIGEST 322-1BL00-0AAD

PR oI ATTr T D 7 T

P Hardware Comparison ﬁ
25 [msToR | \ [ 4

CLICK I

Right-click on Hardware to select the
Download to CPU function.

Hardware configuration data

is now downloaded to the CPU.
Parameters are assigned to the
modules.

Online/Offline comparison

Click on the Hardware Comparison
tab.

r( The view “Hardware Comparison ” is opened

Here you can verify consistency

between configuration data on your PG

(Offline) to data downloaded to the

CPU (Online).

417

Existing data inconsistencies are

indicated in pictograms and details are

returned in the delta list.

Hardware - Project
Rack 0 |Rack1 | Rackz | Racka] [ |
% Offline Online )
P, v oty fr. — J
— 1 |P3 307 24 BEST 307-1BA0... | B |P5 307 24 BES7 307-1BA00-0AA0
2 |CPU 1S 6ES7 315-1AF0... | B | CPU 315 BES7 315-1AFD1-0AED
1 34 5 6 7 4 % 1011 3
4 |5M 321 01.., €EST 321-1BHO... |k |SM 321 DI ... |BEST 321-1BHO0-DAAD
2 5 |SM 322 DO... |6ES7 322-1BH0... | Bh |SM 322 DO... |6ES7 322-1BHO0-0AAD
]
7
)
1 3456 78 91011 9
10
1 11
Delta list:
1 3456 78 91011 1 Rack: 0, Slat 1
Modules are identical
3 Rack: 0, Slot 2
Modules are identical \

1 Rack: 0, Slot 4

Modules are identical

[ Rack: 0, Sht 5

Madules are identical

Comparison

—( For more details on screen )J

Using the instruction Upload to Programming
Device (PG), you can upload a hardware
configuration from the CPU to the PG. This is a
typical service action if you want to access a
switching cabinet with a PG in order to analyze
an error.

Getting Started STEP 7 Lite A5E00293886-01
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Module configuration

Module-related differential
icons

comparison of online/offline/physics

Comparison table:

S, STEP 7 Lite - Getting Started - [H
lll Fie Edit View Insett Options

= H| v || sl G

wdware - Project]
indow  Help

- Project

Rack 0 1 Rack 1 ]

Offline:

onling:
[ Rack: 0, Slat

Cormparisan
[ Rack: 0, Slat

Cnlife phy, char.

* Offline-Cnline 7 1iFs)
Update all (FS
CFfline ghy. char. ¥ Modules are identical

Rackz ] Rack 3 ]
Offline
Order number

BESY 307-1EAD0-0440
6ESY 314-1AE34-0AB0

BESY 321-1BHO0-0440

SM 322 DO, |6EST 322-1BHO0-0AAD

1

BEST 307-1EADD-0AAD
6ES7 307-1BA00-0AA0

3l |
] Slot | Module
| = 1 |PS 30754
= 2 | CPU314
1 345 6 7 8 91011 3
4 |SM3210I...
SIEMENS 2] 5
[ 6
% Getting Started @ | 7
' Hardwarel =] _} F
pid =
E3| Symbol table I3 456 78 91011 g
ﬁ MonitorModify 10
.
M Cross-refersnces lv\,l- - u
|
g Project dacumentatian i
I ist:
2 program . || Delta list:
="
[Z) DE&:S_Data L i 34506 78 9101l 21 Rack: 0, Siot
i FCl:F‘.a” L Different modules
[5) DB2:Diesel th Offline:
[Z) DBL:Petrol L] Al
nline:
i} FEL:Engine L]
1} OB1:Main_Program B 78 91011 21 Rack: 0, Slot
: 0,

2

Different modules

BEST 314-1AEG4-0ABD
BES7 315-1AF01-0ABD

4

Modules are identical

Online
Module Order number

1 PS5 307 28 BEST 307-1BA00-04A0
G | CPU 315 BEST 315-1AF01-0ABD

[ |SM 321 D0I... 6ES7 321-1EHO0-DAAD
B |5M 322 DO.,. | 6ES7 322-1BHO0-0AAD

e, Online-CPL

...displays the difference between the configuration
entered on the PG in the Project tab (offline) and the
configuration downloaded to the CPU.

... displays the difference between the configuration
entered and the physical hardware inserted.

...displays the difference between the configuration
loaded and the physical hardware inserted.

Getting Started STEP 7 Lite ASE00293886-01

5
El
e [P Hardware Comparison ﬂ_ Hardware Configuration b Hardware Diagnostics
iy T eToR T
.
Overview

In the Hardware Configuration tab,
enter your hardware as described
above.

If errors have occurred, perform a
consistency check of configuration data
via Hardware Comparison tab. Details
on this topic will follow.

If problems persist, it could well be that
modules are defective. Perform a check
via Hardware Diagnostics tab. Details
are found in Chapter 12 under "Error
diagnostics”.



How to detect errors:

You have downloaded the configuration
to the CPU and called the Hardware
Comparison tab.

In your project window, Hardware is
marked with a collective pictogram.
This indicates that one or several
modules do not match.

Pictograms on the Rack modules
identify these modules.

Compare: Offline - Online

Online: Configuration which was down-
loaded to the CPU.

Offline: Configuration on the PG.

When you click on Hardware Compari-

son, the Comparison: Offline-Online
button is selected by default. The Delta
list displays the differences in your
configuration and parameter assign-
ment.

Compare: Offline - Physics
Compare: Online - Physics

Physics: Refers to the configuration a
CPU will recognize automatically,
without prior configuration download.

Click on the corresponding button to

compare the Online/Offline
configuration with the physics.

Getting Started STEP 7 Lite A5E00293886-01

4.19



4.20

Module configuration

Symbols

These are the essential icons of the hard-
ware configuration.

The configured module does not match
the module of the Online CPU.

The physically inserted module matches
the configured module, however, it has
been assigned different module
parameters.

The module is configured, but does not
exist online.

Symbolizes a "Possibly identical module”.
The type of the physically inserted module
matches the configured module. It cannot
be determined whether the order numbers
also match.

Getting Started STEP 7 Lite ASE00293886-01

Operating mode RUN
>
@ Operating mode STOP

) Operating mode HALT

@ Error

Symbols (Icons)
For more information on symbols use the quick
info icon.

Under F1 > Index > Symbols (Icons), you can
find an overview of icons which can be displayed

in the project window, rack and comparison table.



Creating the
symbol table




Creating the symbol table

Absolute programming

Woczev 0000

Output
module
Byte 4

W

module
SeLEGTOR Byte 0

» @ a

Input Output
module module
Byte 1 Byte 5

Absolute address: | 0.5

| ™~

Input Byte O Bit5

How to assign addresses

Chapter 4| describes how absolute
addresses are assigned during hard-
ware configuration. As a reminder:

Due to the hardware structure, every
Q4.2 input and output is assigned a default
absolute address.

Q5.0 The absolute address can be replaced

Q51 by a freely selectable (symbolic) name
: (e.g. Q 4.2: Automatic_mode).

Q5.2 Symbols are assigned independent of

the programming language, that is,
LAD, FBD or STL.

Getting Started STEP 7 Lite ASE00293886-01



Symbol table and absolute
( Window is opened for
H project selection addresses
CLICKI o Open STEP 7 Lite. In the Open

project window, Click on the "Getting
“Getting Started” is opened started.k7p” project you have created
in Chapter 4.

-4 STEP 7 Lite - Getting rted - [Symbol table - Project]
S £ie E View lnsat Qpiors \Whdow Help T

s
BT T TR

Your project currently consists only of
default project elements and of the

- — program element OB1.
Lﬁ ; e In the project window, double-click on
g . I the element Symbol table.
"o cLicK |
The symbol table currently consists
only of the default organization block
OB1.

[

Additional entries are not required if
you choose to work with absolute
addresses in your program. Simply
close the window again.

Symbolic programming is used for the
sample project. Proceed as described
in the pages below.

You should only use absolute programming if you
have to address only a small number of I/Os in
your STEP 7 Lite program.

Getting Started STEP 7 Lite A5E00293886-01
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Creating the symbol table

Symbolic programming

Filter table (e.g. display outputs only)

72 S5TEP 7 Lite - first_steps_lad - [Symbol table - FProject]

IE_EiIe Edit “iew |Insert Options “Window Help

Change sorting order

9%

clicking in the header

LTI

Jnﬁ

E CPU offline F-3Ml| Symbol table - Project ||
Filter Shaw al 7 Edit Filter... | Display addresses without symbals
Skatus | Symbol  © Address | Data Type | Comment
Autornatic_Mode Q4.2 BOOL Memary Function Elaborate Comments
Aukomatic_on 105 BOCL For the memary Function {switch on) .
DE_Actual_Speed MW 4 INT Actual speed for diesel engine
DE_Failure 116 BOOL Diesel engine Failure
DE_Fan_Cn Q5.6 BOOL Command for switching on diesel engine Fan
zj First_sheps, lad DE_Follow_on T2 TIMER. Fallaw-on time Fo-r difesel enqine Fan .
DE_Cn Q5.4 BOOL Command for switching on diesel engine
Ill Hardware DE_Preset_Speed_Reached |Q5.5 BOOL Display "Diesel engine preset speed reached”
o] E Diesel DE 2 FB 1 Data For diesel engine
ﬁ Monitor Madify Engine FE 1 FE 1 Engine cantral
M Cross-references Fan FC 1 FC1 Fan contral
Green_Light Q4.0 BOOL Coil of the series connection
Copy SymbOI table Kew_1 0.1 BOOL For the series connection
between prOjeCtS Key 2 10.2 BOOL Far the series connection
— e Key_3 10,3 BOOL For the parallel connection
Key_4 10.4 BOOL Far the parallel connection
6 BEEHS IDER Main_Program 0B 1 0B 1 This block contains the user program
ik Fe1:Engine Manual_on I10.6 BOOL For the memory Function {switch of F)
{7+ FCLiFan PE_actual_Speed M 2 INT Actual speed for petrol engine
Symbols Absolute addresses

Q 4.2 Automatic_Mode

Q 5.0 PE_On

I 1.0 Switch_On_PE

— T

Q 5.1 PE_Preset_speed

I 1.1 Switch_Off_PE

Q 5.2 PE_Fan_On

| 1.2 PE_Failure

Getting Started STEP 7 Lite ASE00293886-01

The symbol table

In the symbol table, assign a symbolic
name and data type to all absolute
addresses you want to address in your
program, e.g. assign the
"Automatic_On” symbol to input 10.5”.

These names, referred to as global
symbols, apply to the complete project.

Symbolic programming can
considerably improve readability of your
program.



=4 STEP 7 Lite - Getting Started - [Symbol table - Project]

@jf\le Edit “iew Insert Options Window Help

(Sl [ i | SR s mmH [0 |2

- mimr w2

Symbol table - Projecl

Fiter = EditfFiter.., | Displdy addresses without symbols
Skatus | Symbol © Addless | Daka Type| Commient
CYCL_EXC (o] OB 1 Cycle Execution
7 Automatic On {05 ) Bool  {(Forthe memory Function {(switch on
Sj Getting Started ]
ll] Hardware ]

ﬁ MonitorMadify

2 Cross-references

£ Project dacumentation

ﬁ Program G

{}OBL:CYCL_EXC 24

A second instance of
STEP 7 Lite is opened

g
Cuick]

=3 STEP 7 Lite - Getting Started - [Symbol table - Project]
File Edit Wiew Insett Options Window Help

IS [=1 E3 |6
=181 %]

STEP 7 Lite - f rs_sweps_au - Laymuw
Fie Edt Wie

Insert  Options  Windol

| = W~ W i | @ N[ 5 W | oo | BESTERIEHD

= T

J o Cx J ) Cx
[ e N LNl Symbol table - Project B cru otiine A
SIEMENS Fitey Show all - Edit Filter..., | SIEMENS. ol | Fiter
Status | Symbel - | Address | Data Type| Com = || Status
Automatic_Mode Q4.2 EOOL Meme
- Automatic_On 10,5 BOOL | For tt
4 ~ Actual 7 EIERT)) —o
silure b
7] DE_Fan_on Q56 |BoOL W Comn m
5] Getting Started 7 DE_Fallow_On T2 TIMER Follow
7 |DEOn Q5.4 |BOOL  Comn T
v Hardware L] T 0T R t
Symbal table! 7 |Diesal o6z |FB1 Data ool table
ool Moriter Modify, 7 |Engine FB 1 FB1 Engin o +{Modify
X Crossreferencls T |Fan FC1 FC1 Fan c H n “
2 Project documehtation 7 |Green_Light Q4.0 EOOL Colo @ra CLICK |
= Program @ T Keyl 10 BOOL  Forth B
{7} 0B1:Main_Hlogram 53 T |Key 2 1.z BEoL For tf {5 DB1:Petrol
E 10.3 BOOL  Forth £ DB2:Diesel
h 7 |Key_4 10.4 BOOL  Fortt Ry
Main_Program OB 1 OB 1 Thisk -
7 Manual_on 106 BOOL  Forth Lt FBL:Engine
CLICK I 7 | PE_Actual_Speed | MWz T Actuz £k FCLiFan
7 |PE_Faiure 11z BOOL  Petro L} 0B1:Main_Frogram
7 |PE_Fan_On Q5.2  |BOOL  Comn
2 o- el 1 TER Eal

Filling out the symbol table

In the Symbol column, enter
"Automatic_On” for address ”10.5”.
In the Comment column, enter the
comment as shown to the left.

During input
Return =
Ctrl+z =

One row down
Undo

Save your entries via File > Save.

How to copy the symbol table

Since quite a large number of symbols
are used in your "Getting Started”
project, copy the symbol table from one
of the included sample projects.

Also open the project
“first_steps_lad.k7p” in a second
instance of STEP 7 Lite.

In the "first_steps_lad” project, right-
click on Symbol table to open the
pop-up menu. Select Copy.

In the "Getting Started” project, right
click in the project window to open the
pop-up menu. Select Paste.

You are prompted to confirm over-
writing. Confirm with "OK”.

Close the project "first_steps_lad”.
Save your "Getting Started” project via
File > Save.

Getting Started STEP 7 Lite A5E00293886-01
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Creating the symbol table

BOOL
BYTE
WORD
DWORD

- Data of this type consists of bit combinations. 1 Bit (Type
BOOL) up to 32 bit (DWORD).

CHAR

- Data of this type uses exactly one ASCII character.

INT
DINT
REAL

- Data of this type is available for processing
numerical values (e.g. for calculating
arithmetic expressions).

S5TIME

TIME

DATE
TIME_OF_DAY

- Data of this type represent different time and date values
within STEP 7 Lite (e.g. for setting the date or input of
the time value).

Getting Started STEP 7 Lite ASE00293886-01

Data types

Data types determine the type of
signals a CPU has to process.

STEP 7 Lite uses, amongst others, the
data types shown on the left.

You will find more information on data types (e.g.
permissible ranges of values and application
samples) by clicking the help pointer on a data
type and then jump to Introduction to data
types and parameter types.



Getting
started with
programming




Getting started with programming

Choosing LAD, FBD or STL

Page 6.6/to 6.11
Ladder logic (LAD) is
appropriate for users
e.g. in the industrial
electrical sector.

Getting Started STEP 7 Lite ASE00293886-01

" KeY_l n
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"Gr eeﬂ'_quht

Page 6.12 to 6.17
Statement list (STL) is
appropriate for users
e.g. in the information
industry.

Page [6.18/to 6.23
Function block diagram
(FBD) is appropriate for
users e.g. in circuit
engineering.

In STEP 7 Lite you always create your
program in the same programming
interface, namely the block editor,
regardless whether you choose LAD,
FBD or STL. The user interface is
adapted according to the programming
language you have selected.

For example, if you choose to program
in LAD, refer to the information on
Page 6.6/to 6.11.



G ¢ Opening OB1
| 7 [ The dialog box for
STEP 7 Lite selection is opened. Open STEP 7 Lite.

Open Project K E3

..
STEP7,;, -5l
- s o B
[ Create From online CPU M hL X
Last processed l File sy,

In the Open project dialog, click on
the "Getting Started.k7p” project.

File name Modified
fing Started kip DHVSLep? s vOD\E<ampls Z1.01.2002 11,57 You have already generated this
:—,gﬁrst_steps_stl.k?p CiSiemensS7Lite Examples\English - 30,07,2001 10,26 prOjeCt as described in Chapter 4 and
2 first_steps_lad k7p  Ci\SiemenstS7Lite\ExamplesiEnglish - 30,07.2001 10,26 . . .
filled out a symbol table for this project

as described in Chapter 5.

If this is not the case, simply open a
"New project” and copy the symbol
table from one of the included sample
projects.

[ &lways open current projsck Open as copy. | Cpen Cancel |

STEP 7 Lite is opened. )J

e - Getting Started - [DB1:Main_Program - Project]

Insett Test Oplians Windaw Help e Double-click on OB 1 to open the block 6.3

L&D Cul+1 FES7 321-1BHODOA v b§ editor in your working area.

STL Cil+2

FED Chil+3

Parme Type Start walue
® Block Editar . . .

—— Tt c Click on View. This menu shows you

. N QB1_PRIORITY BYTE H

Disalay With H| e the currently selected programming

Zaom In CukNUM+ language; LAD, FBD or STL. Here you

2:51 P "Wain Program sweep (Cycle)’ can also change the view.

ZjGett\ng 5taBEE| Project Overview Chrl+alt+T
IﬂHard argproieclgocumentation NOte-
&5 Symiplt Wl Hardwere i’ Some of the instructions cannot be
ﬁMnni' ol &8 Spmbols Chrl+diftsy . . .
3¢ Croshte. ol MoniexModiy . displayed in all three programming
58 Projett ¢ 0 Crossreferences ’ languages. These are always displayed
ﬂ' Proguarn ﬂ' Program 4 |n STL
el ’ You wil find information on th
Address Overview Chl+F10 . Ou \_NI Ind informa Ioln on e
, individual commands in LAD, FBD and
|| CL'CK] STL via F1 > Index > Language
- Descriptions.
You can work in the block
editor.
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Getting started with programming

Working in the block editor

Change view of the The most important
programming language commands for LAD and FBD Insert new network

Show/hide CPU Variable declaration Switch symbolic/ absolute
control panel table programming

=15 'EP 7 Lite - jefting Started - [0B1-Main_Program - Project]

Address | Daclaration Mame Type Shart value Comment -

0] ternps OB1_EV_CLASS BYTE Bits 0-3 = 1 (Corning ewent), Bits 47 = 1 (Event

0 |temp OB1_SCAN_L EBYTE 1 (Cold restart scan 1 of OB 1, 3 (Sean 2 of €

|temp OB1_PRIORITY EYTE 1 (Priority of 1 is lowest)
temp OB1_OB_NUMEF. EBYTE 1 (Organization block 1, 0B1) _Ij
»

4 |

OB1: Main_Program "Main Frogram Smeep (Cpcled”

Comment:

@)Gettingstarted Q||

iy Hardware Q| |f EEEERE-S )
: < (M)

5 Symbol kable O P

2o Moniter fModify 45 —{SAYE)
J{ Cross-references T neG
T ros

5 Profect documentation I

(€] Comparator

17 Program @
& T EZE:Z:”
-
DE call
(&] Jumps

[21] Integer fit.
|2#] Floating-point fet.

[~

Program control

shift/Rotate

tatus bits
Timers

|22 word lngic
Multiple instances

MOnIme-CPU % {5 BlackEdtor /{5 Propertis Bideks
ERSAE i N T [

Project element “Program”

| All commands
for LAD and FBD

Program element “OB 1”

' A click with the help pointer
Title and comment area calls the reference help
on network

Network for

program input You always program blocks in the

block editor.

We have inserted a view of LAD to

ify block ies:
Specify block properties represent the programming languages.

e. g. change symbolic name

Getting Started STEP 7 Lite A5E00293886-01



Ej first_steps_lad
lll Hardware
&) symbol kable
ﬁl MaritarMaodify
M Cross-references
g Project documentation
ﬂ' Program
[~ DB1:Pstral
[=] DB2:Diesel
[ DB3:5_Data
i} FE1:Engine
i FFC1:Fan
{ } ©B1:Main_Program

Project element “Program”

STEP 7 Lite user programs are split
into blocks, thus allowing you easy
management of large programming
projects.

These blocks are displayed below the
project element Program.

A new project only contains OB1 that
STEP 7 Lite generates automatically.
Later on in your project, you are going
to add other blocks, e.g.:

OB = Organization blocks
DB = Data blocks

FB = Function blocks

FC = Functions

The organization block OB 1 is the
CPU’s operating system and it contains
the main program. Additional blocks are
mostly called in OB 1 and the specific
parameters necessary for controlling
the processs are assigned here too.

You can rename blocks using the Rename
command of the pop-up menu.

Newcomers may require more information on
working with blocks. Access this information with
left-click on the project window and then press F1
> Index > Blocks in the user program.
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Programming OB 1 in LAD

=2 STEP 7 Lite -
34 Fle Edt

=av
B cortroit

L

D) *roject

Block Editor

[ Fropeties

Created in Language

Symbol Comment;

Display With

Zaoi eI

Zoorm L Ci UM Interface
m Zoorm Factar
] Getting Sta 25 Project Dverview CllelteT

05.03.2001 19:07:00
W) Hardwar £ Project Documentation

&5 Symbol t Wy Hardware »
oy monicorl 5] Symbole Cllslhsy
I crossre 1) Moritor/Maciy
58 Praject ¢ 3 Crossteferenc
€% Program 1% Program

Wersiary

Author

Load memory equitement

B otk memory requiement
b CulFiD

“ustamize

CLICK]

F5 o e PIC Stanidard block

Bausta ot UITED)

v [FAuliple rstance complr:

i

Tt [t contains the

= Gy Bk g

> 45

108 Bytes

38 Bytes

oy

{54 Block Edior ; {5 Proper

onver
ounte
B call
umps
Brteger

tatus
mers

=
Huliple
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In the following section you will
program a series circuit, a parallel
circuit and the set/reset memory
function in LAD (Ladder logic).

Specify the programming language to
be used in programming and opening
OB1 in future:

Double-click on OB1.

Click on Properties.

Select LAD. As of now, OB1 will be
opened in LAD.

Exit the Properties dialog box. LAD is
now marked in the View menu, too.



;;- STEP 7 Lite - Getting Started - [DB1:Main_Program -
£t Fle Edi [IE lnsert Test Options ‘window Help

Project]

= H vt Cti+1 EEST 321-IBHO0AA ~ dhi 8t K2 ||} 4 O ]
T Otz
Hurcoiat gy otk
. Hame Type Start walue Comment
*® Block Editor OB1E¥_CLASS BVTE Eits-3.= 1 (Coming
Properties OB1_SCAN_L BYTE 1(Cold restart scan 1 of|

Displag With

1 (Priarity of 1is lowest

1 (Organization block 1

3% Fle Edt View lnset Test ptions Window

= B v || e sl i | S

Name.
0B1_EV_CLASS
OB1SCAN_L
OB1_PRIGRITY
OE1_OE_HUMER]

Type
BYTE
BYTE
BTTE
ETTE

BES73211BHOD0AA v ai Mt | KD

Ak 4 O &

11y processed main

B

agr

< ~(5)
155 ] Getting Started )
iy Herdnars s=r s
& Symbolteble i E:))
ol Moritortiodfy <5 ~(SAVE)
3 Cross-references {1 neG
5B Project documentation I ‘ £] pos

£, 5TEP 7 Lite - Gelting Started - [0B1:Main_Program - Project]
5§ Fie Edt Yiew Inset Test Oplions Window Help

SHlvWhdidh SN dBRX | o

OB1EY_CLASS
OB1_SCAN_1
OF 1_PRIORITY
OB 108 _MUMER

EEST 321-1BHOD0MA v  dhi M

“Peridically processed ma

155 Getting Started
il Hardware crina in
] Symbol table

ol Monitor oty

X Crossreferences .2
53 Project dacumenkation -

2 program

£ STEP 7 Lite - Getting Started - [0B1:Main_Program - Project]
{5} Fie Edt ¥iew Inset Test Options Window Help
e H| v | W sl o | S ©

[l R e MLy P Yl 0B1:Main_Program - Project

Name. Type

=l G Bt logic
A -
A i

o
<0

< (P}
< ~{3AVE)
] ne

pOS

(<1 Comparator

21 (3] Counter
= (ge) DB cal

MEIE
ads |-

159 N network
=1 i it logic

e o1 BV CLass erte ) Bis 47 = 1 (Ewent
1.0 temp. OB1_5CAN_1 BrTE of OB 1), 3 (5can 2 of € -
2.0 temp OB1 PRIORITY BYTE A=l
sl 3.0 teme OB1 OB NUMER |BYTE 2 A ~wor]
s » o ()
2] o (R
<« (5)
(%] Getting Started Q flrs
il Hardware Q £ ST )
= O (i
5] Syl table ol
= < ~{5AVE)
J Cross-references Ereen L 1gnT £ nes
<5 Profect documentation { Fros
7 ~ 7 &1 (3] Comparator

Orline-cPL

& {7} BlockEditor

25 e

Abs

Froperties

1 (agl Converter
&1 fed] Counter
1 (o) OB cal
2 (gl Jumps
1 (e Integer fet
1 (28] Floating-point et
= () Move
1 far] Pragram cartral
= (g Shitirotote
1 fan] Stabus bits
1 () Timers
21 (3l Werdloge
& Mubple instances

|

How to program a series circuit in
LAD

Under View, select symbolic

representation.

At OB1, enter “Periodically processed
main program”. At Network 1, enter
"Connecting in Series”.

Click on the empty circuit to highlight it.
Insert three program elements, using
different methods:

Click on the NO contact icon to insert it
immediately.

Right-click on the circuit to open the

pop-up menu. Select NO contact.

Drag the coil to your circuit using the
drag-and-drop operation.

The addressing of the NO contacts
and the coil is still missing in the series
circuit:

Click on ??.?. Enter the symbolic name
“Key_1” (with quotation marks). Or,
click on ??.? to open the symbol
selection list and select the name.
Confirm with Return.

Enter the symbolic name “Key_2” for
your second NO contact.

Enter the coil name “Green_Light”.

Getting Started STEP 7 Lite A5E00293886-01
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ogram - Project]

5] etting Started A
@«

Wl Hardware:

&5 Symbol table

ol Monitorjtodify

X Crossreferences

(&3 Project documentation

(Coning svent), Bits 4.7 = 1 (Event

0B1.5CAN_1

erTE

1 1cF OB 1),3 (Sean 2 of €

OB1_PRIORITY

BYTE

1 (Priority of 115 lowest)

1 ew networ
= G sitlogic

“Green_Light"

({529 Online-CPU

Pos
(<] Comparator
sl Converter
Counter
06 cal
&1 Jumps
21 Integer fet
28] Floating pai
Move
Program cont
(2 shft/Rotate
Status bits
(o) Timers
(2 Word logic
Multiple instaf

A {7} Block Edtor /5 Propertios
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The series circuit program is
completed.

If no other icons are displayed in red
color, click on the disk icon to save
your entries.

Not only your entries in OB1 are saved,
but rather all project elements.

When you select Edit > Apply, your
entries (always the content of the
active window) are saved to a
temporary file.

This file saving method is recommen-
ded in case you intend to undo chan-
ges later. After applying data, you are
prompted to save your changes when
you close the project.

Symbols are displayed in red color, for example, if
not included in the symbol table or if a syntax
error has occurred.

In this case you cannot save your entries, and
the lower section of the editor displays a plain
text message informing you of appropriate
procedures.
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{7f Fle Edt View Inset Test DOptions Window Hep

=25 W s ol B0 | S

Bl R eI Eey SRl | 0B1:Main_Program - Project 7

ress Mame.
0]temp 0B1EV_CLASS
L0 temp oB1_SCAN 1

20 temp OB1_PRIORITY

k7

Tupe Start value
BYTE

BvTE 1
BrTE 1 (Priority of 15 lowest)

k), Bits 47 = 1 (Event
OB 1), (Sean 2n

o<

rE How to program a parallel

circuit in LAD

Highlight network 1.

x iy
2 Crassreferences

"Grasn_Light"

5 Project documentation

PEEREpDEE

=
mps
teger fit.
oating-point fct.
ove
—

(369 Program contro

&) Multiple instances

Insert a new network.

This action can also be performed via
an icon in the toolbar, via context-
sensitive menu or CTRL+R.

Again, highlight the circuit.

Orline-cPU

25 s

Abs

|

A {7f BlockEdior / {5 Properties ¢

N 2

- Pioject

OB1_EV_CLASS BYTE
OBL_SCAN_L ETTE
P OB1_PRIORITY BYTE
OB OB _NUMER BYTE

BEST 321-1BHO0-064 ~  dhi dht 7 1F #

Shart value Camment

Btz 0-3 = 1 (Coming event), Bits 4
4(Cold restart scan 1 of CE 1), 3
1 (Priority of 15 lowest)

1 (Crganization black 1, 0B1)

ogram "Peridically processed main progran®

"Green_Light"

"Rad_Light"
T

EEEEEEEEE

Libraries

i
= [ Bit logic
—| [= (1 camparatar
| (ag] Conwerter
# (&4] Counter
[og] DB call

(&1 Jumps

[21] Integer fet,
(28] Floating-point fit,
(2] Move

(3 Program control
(] Shift/Rotate

] Status bits

(] Timers

(2 word logic

& Multiple instances

Insert a NO contact and a coil. Name
them "Key_3” and "Red_Light”.
Highlight the left circuit.

Insert a parallel branch and add
another NO contact to it.

Close the branch-off via icon or drag-

The only thing our parallel branch is

entries.

Assign distinctive short-names to your circuits.
This makes it easier to scroll through large
programs via scroll bar on the right side of the
window. The names are displayed when you
scroll the view.

Getting Started STEP 7 Lite A5E00293886-01

ging the double arrow tip that is visible
after you have inserted the NO contact.

now still missing is addressing. Enter a
name as shown in the figure. Save your

6.9
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15 Getting Started =

) Hardware Q| || Mptmerk 1 s Conmecto in Saries

Feridically processed main progran”

mnents

& Symbol table
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Program conl
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% Block Editor Propertios

£,5 EP 7 Lits - Getting Started - [DB1:Main_Program -
{7f File Edt View Imet Test Options Window Help
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terp
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195 Getting Started =
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il Hardware
& Symbol table
ol Monitorjtodify

X Crossteferences ‘

Metwork 1: Cormecting in Series
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“Key 1" Koy 2" "Green_Light"

3 Project documentation r
£ Program @
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[OE1.:Main_Progran|

Comnent
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1 Comparator
&9 Converter
Courter
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Wove

Program cont
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Status bits
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Multiple nstaf
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How to program memory
functions in LAD

Highlight network 2, insert another

network and enter the title "SR Memory
Function”.

Again, highlight the circuit.

In the Command tab, go to Bit logic
and SR element. Insert this element.

Insert a NO contact upstream of input
S.

Enter following symbolic names:

— Upper NO contact: "Automatic_On”,

— Input R: "Manual_On”,
— SR element: "Automatic_Mode”.

Save your entries with File > Save.



“Grazn_Light"

How to adapt the
programming interface

You can use STEP 7 Lite menu
commands to customize your
programming interface.

View menu - Examples:

Enable View > Display with > Sym-

o For symbolic addressing in LAD:
bolic Representation.

e For absolute addressing in LAD:
Disable View > Display with > Sym-
bolic Representation

Changing the programming language:
View > LAD/FBD/STL

Menu command Options > Settings -
Example:

- Settings

Black editor

LAD/FED
Layout:

Address field width:
Display:

Selected element:

Status fulfilled:

Status nat Fulfilled:

LIk A4 Porkrait

24

2-dimensional

i

Specify a line break in symbolic
a addressing, between the 10th and

24th character:

Options > Settings > LAD/FBD

> Address field width

0K Cancel

° Modify the color setting of a circuit:
Options > Settings > LAD/FBD
> Selected element

Close the block via Windows icon
Close.

Especially menu item Options > Settings

offers a wide range of options for the
customization of colors, fonts, address field width
etc. of the STEP 7 Lite user interface.

Getting Started STEP 7 Lite A5E00293886-01
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Programming OB1 in STL

"KeY_Z" ) "
" Greeﬂ__nght

'-STEPTLlIIIngSlalled-[Dlﬂ Main_Program - Project] -[5] USIng the prOgrammlng Ianguage STL
£5f File Edt Inset Test Options Window Help INEIE . .
= RV (Statement list), you are now going to
[ mlerlr rogram an OR and an AND
e prograr
s (BT instruction, as well as a set/reset
S Getting Sta  picoiay with » reated in Language: sTL - .
B 7o e \— memory functions.
3¢ Cross-re = Interface
A (S CLICK |
sy W) Hardwzre » Jooz 10:08:31 | 05.03.2001 12:07:00 — .
"@;W Specify the language you want to use
Monitor/Modify v Wersion:
' to program and subsequently open
L — OB1:
Customice T ok memey reatement o -
:Eistwnte:r::te(tedunthsPlC Z:i&j::;\n(k ‘ Double_cllck on 0B1 .
e Click on Properties.
Select STL. As of now, OB1 will be
e ) 8 o opened in STL.
Changes the programming language of the current block to STL. g:ﬁ b

Getting Started STEP 7 Lite

A5E00293886-01

Exit the Properties dialog. STL is also
marked in the View.



., STEP 7 Lite - Getting Started - [0B1:Main_Program - Project] HOW to prog ram AN D

£t Fle Edi [IE lnsert Test Options ‘window Help

Er=T cite] 2 - mimr A2 instructions in STL

. 5Tl Otz
=@ [ e o]

M * Block Editor

Properties Mame Type Latbacal L
i e Eits 0-3 = 1 [Coming e
(Getting Sta - i e iic
Sj.| " f — Blantinte 1(Cold restart scan 1 of]

spnﬂmdumrﬁnm sl At OB1, specify "Periodica”y Proces-
Ei]ci‘mm‘\:heguf;:;@l < Poject - Sed MaSter Progl’am" At Network 1,
e | R ﬂ B enter "AND Instruction”.

L]

10 terp 081 scANL ore
il Hardware

& Symbol table

Select Symbolic representation from
the View menu.

OB1_PRICRITY BvTE

oB1I0BTWMER BYTE
) MoritorjModiy
8 Cross-references in_Progfes "Pericdically Processed Hain Progran” ]

46 Project documentation

@ rrogran

% OB1:Main_Program 1

° Click on the input area.

% 5TEP 7 Lite - Getting Started - [0B1:Main_Program - Projeot]
{54 Fle Edt Wiew Inset Test Options ‘window Help NEIE

SH Y Eads s Y oo |- - w2 [@ @ o Enter A’ (for AND) in the first program

3] 121 control the cPUOnine & | ([T HAETNG T C
S e network.

| e line, followed by an empty string and
Pl me e ol e the "Key_1” symbol (with quotation

el 20 tamp OB1_PRICRITY BvTE 1
&5 Symbol table

3.0 temp OB1_OB_NUMER BYTE 1(Orgar bl
ey | \ . marks)

J Cross-references -
i “eriodically Processed Hain Progran® =

£ Project documentation v &

& Program

% OB1:Main_Program 2

Close the row with Return.
The cursor moves to the next row.

T

CL|CK] a In the next row, enter an "A” once
again. This time, right-click on the input
area.

Right-click to open the pop-up menu.
Select the menu command Insert sym-
bol. Select "Key_2” from the list and
insert it.

In the next line, enter =", and then
"Green_Light” either via the keyboard
or the pop-up menu.

You do not have to start making your entries at
the beginning of an input row. No matter where
you start, STEP 7 Lite arranges the instructions
clearly and in rows.

Getting Started STEP 7 Lite A5E00293886-01
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75 STEP 7 Lite - Getting 5Started - [DB1:Main_Program -

@Eila Edit View Inset Test Options ‘Window Help

Project]

The program for your AND instruction

E [2] Chritrol the CPU Online %% | (LLE a 0g

= R T A O =S S T I s

Harne

Tuins

is completed.
v #hi b

— o If no other text is highlighted in red
color, click on the disk icon to save

OB1_EW_CLASS

EYTE

OB1_SCAN_L

EYTE

OB1_PRIORITY

EBYTE

your entries.

00|
Getting Started Q& —
1.0
M0 | temp
ll] Hardware L]
2.0 temp
@j Symbal kable 3.0 temp
ﬁ tonitor/Modify 2|

OB1_OB_MUMER

EVTE

M Cross-references
§ Project documentation
1F Program =’}

Comment :

"Kay 1"

{8 OB1:Main_Program Hetwork 1): AMD Instruction

e
"Grean_Light"

0BL: Main_Program "Pericdically Processed Main Progran”

Not only your entries in OB1 are saved,
but rather all project elements.

@ When you select Edit > Apply, your
entries (this is always the content of
the active window) are saved to a
temporary file.
This file saving method is
recommended in case you want to
undo changes later.

Getting Started STEP 7 Lite ASE00293886-01

After applying only data, you are
prompted to save your changes when
you close the project.

Symbols are displayed in red color, for example, if
not included in the symbol table or if a syntax
error has occurred.

In this case, you cannot save your entries and
the lower section of the editor displays a plain
text message informing you of appropriate
procedures.
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Name

OB1_EV_CLASS
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BVTE

@ | e

{3 CB1:Main_Program Q1 | || Metwork 1 : SMD Instruction

Comment:

5 ey

A "Key 2"

= Grean_Light"
et 15 OR Tnstruction
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By Hord = OB1_SCAN_L BYTE OB 1),3 (Sean 2-nof & |
W Rardware: BT TRIONT e o
Symbol table 3.0/temp OB1_0B_NUMER. BvTE 1 {Organization block § OBL) -
2 Moritor/Modify 1] »
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0B} : Main_Program "Periodically Processed Main Program” —
58 Project documentation Frog v &
Coffment:
= program Q

4 STEP 7 Lite - Gelting Started - [DB1:Main_Program
ﬁ Eile Edit “iew |nsert Test Options Window Help

- Project]

How to program an OR
instruction in STL

Highlight network 1.

Insert a new network.

This action can also be performed via
icon in the toolbar and via right-click or
CTRL+R.

Again, click on the input area.

Enter an "O” (for OR), followed by the
"Key_3” symbol (analog to AND).

Comment}

& B v [ 2 du 0| B G[TF = ~RTET R e W
EEIE] etk Al OB 1:Main_Program - Projsct
'_1 Address Declaration Mame Type Start walue Comment
I o temp OB1_EV_CLASS BVTE Bits 0-3 = 1 (Caming &v
Getting S I -~
zj'l " j CLICK 1h temp OB1_SCAN_L BVTE 1 (Cold restart scan 1 of|
i Rarche. ! 2p temp OB1_PRICRITY BVTE 1 (Priarity of 1 is lowest
Symbol table feme B1_CE NUMER EIIE L(Organization block 1
28 Mornitor[MadiFy 4 |
M Crossreferences -
i 0B1: Myin_Program “"Periodically Processed Main Progran”
&35 Project documentation
Commen'
1 Program @
{5 OB1:Main_Program ‘& Hetworf 1 : AND Tnstruction
Commend
A "Key_1"
o ey 3"
4 “Grean_Light"
Hatworf “2: Of Instruction

"Key_ 3"

ey 4
"Red_Light"

Complete the OR instruction and save

a your entries.

6.15

Assign distinctive short-names to your circuits to
make it easier to scroll through large programs
via scroll bar on the right side of the window. The
names are displayed when you scroll the view.
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Comment s

Comment:

Hetwork 4 sfswitching on the Petral Engine

0B1: Main_frogram 'Pericdically Processed Main Progran”
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How to program memory
instructions in STL

Highlight network 2. Add another
network.

Again, click on the input area.

In View > Display with > Symbolic
Representation, you can switch
between symbolic and absolute
representation.

In the first line, enter an "A” instruction
with the symbolic name "Auto mode
ON”. Complete your memory instruc-
tion as follows:

Symbolic:
A "Automatic_On”
S "Automatic_Mode”
A "Manual_On”
R "Automatic_Mode”

Save your entries via File > Save.

If you switched the view in step 3,
enter the following:

Absolute:
A 10.5
S Q4.2
A 10.6
RQ4.2



Iz =

"oy 1"
"Rey 2"
"Green_Light"

Iz

H
=y
=R

Block editor

STL Syntax highlight

Address (global): -
Address (local); —
Address (constants): -
Instruction {command): | -
Instruction {label): == -
Comment: -
arameter (in, —/ -

arameter
Farameter (nout): -

How to adapt the
programming interface

STEP 7 Lite allows you to customize
your programming interface.

Menu View menu - Examples:

For symbolic addressing in STL:
Enable View > Display with > Sym-
bolic Representation

For absolute addressing in STL:
Disable View > Display with > Sym-
bolic Representation

Changing the programming language
View > LAD/FBD/STL

Menu command Options > Settings -
Example:

Changing the color of instructions:
Options > Settings > STL Syntax
highlight

Close the block via Windows icon
Close

The menu item Options > Settings
offers many options for the customization of
STEP 7 Lite colors, fonts etc.

Getting Started STEP 7 Lite A5E00293886-01
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Getting started with programming

Programming OB1 in FBD

et Test Options Window  Help

G ix|n0|7

- | de fE \k?‘

Crit2)

Bemconot  piogk Edior
[ Propattes
B4 'IGEttlng 3 Displsywith » CredledinLanguage: Sy - |
Hardwar
51‘ by .1 Gl T e
ool Zoom 0L Gl
% Moritorfl | bor R o =
Crosse Interface: “Miin Progeamm Sweep (Cycle)"
o B P D CrT 1 Inkeger e,
grom B T CLICK |2t
£ a1 5| Symbols Clrkealter
% 05 ; 2] Monior/Modfy » Version: 00
7 Cross-references »
L ogiam , At 2 Word gic
; , Mulkiple instance:
nine
B [y Load memory requirement ¢ e
CLICK e >
= m— 5
L
Bausteischite. (IRED:
v Ul tple instance carmpliant
Orline-CPU 1 Elock Editor ) ' Properties /
Changes the progiamming language of the currert block to FBD. =7 sToP fbs . ns | Chg
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Using FBD (function block diagram),
you are now going to program
AND/OR/memory functions.

Specify the language you want to use
to program and subsequently open
OB1:

Double-click on OB1.

Click on Properties.

Select FBD. As of now, OB1 will be
opened in FBD.

Exit the Properties dialog box. FBD is
also marked in the View menu.



£t Fle Edi [IE lnsert Test Options ‘window Help

e L&D Cil+1
sTL Chik2
B cruatiine o pgp i3

;;- STEP 7 Lite - Getting Started - [DB1:Main_Program -

Project]

* Block Editor
Propetties

Mame Type —I Start walue Comment
OB1_EV_CLASS BVTE Eits0-3.= 1(Coming
OB1_SCAN_L BVTE 1(Cold restart scan 1 of]

1 (Priarity of 1is lowest

1 (Organization block 1

{7f Fle Edt View Inset Test Opfiors Window

= d W e sl B0 | S5

B 121 Contralthe CPU Cniine ¥

oD D] ([ Declratio] | Marme
0] ey oB1_EV_cLASS
1557 Getting Sterted F) e BV
P 5 10/ tamp oB1_SCAN_
) Rarchuare 20 tamp OB1_PRICRITY
Symbol table: 30 emp 0B1_0B NUMER.

2y onitortadity

L4

Type
BYTE
BvTE
EBVTE
BYTE

ty of 11 loweest)

& & 5B

i), its 47 = 1 (Event
O 1),3 (Scan 21 of €

B New network.
= (3 Bt logic

H Crossreferences
< profect documentation
F Program

£ 0Bt Main_Program

ericdical 1y Processed Main Frogr:

DOplions  Windaw

Help

=l x|

Name Type tart walue - ‘ '
@B1_EV_CLASS BrTE Bils 0-3 = 1 (Coming evert), BiL; fiLaa
L0]temp ©B1_SCAN_L BYTE 1(Cold res 1of OB 13,305 1 >=1
i cormoarJorte L g o st CLICK | 5«
20/teme cBLOBNUMER  [evT 1 blac‘k 1,081 = xor
N ¥
in_Program Perisdically Processed flin Pragran
T
g

DB1:Main_Program - Project

Address Declaration

Libraries

Name Type Start walue Comment - B Mew nietwiork,
00| temp OB1_EW_CLASS EYTE Eits 0-3 = 1 (Coming ewent), Bits 4-7 = 1 (Event =l (& Bit logic
10 temp OB1_SCAN_1 BYTE 1(Cold restart scan L of OB 1), 3 (Scan 2-n of C £l ==1
240 temp ©B1_PRICRITY EYTE 1 (Priority of 1 is lowest) e
20 temp OB1_OB_MUMER EYTE 1(Drganization block 1, OB1) L‘ E #OR
4 ~ ! ¥ = VU.‘
0B1: Main_Program FeriodfEally Fro o Main Frogram 2 o -=
Comment: % ~[#]-
-[R]
£ 51
frs
sk
E 2 J ~[H}-
Peen_Light' % F1-
7 -[savE]
T nes
Tl ros

&

=

o

EEEEEEE

(1 Comparator
2] Canverter

(e Courieer

(8] DE call

(&1 Jumps

23] Inkeger et

[H) Floating-pairk frt,
[l Move

3] Program control
5] ShiftiRatske

How to program AND
functions in FBD

Under the View menu,
select symbolic representation.

At OB1, enter "Periodically Processed
Main Program”. At Network 1, enter
"AND Function”.

Click on the input area.

Use different methods to insert two
program elements:

Click on the AND icon to insert it
immediately.

Drag the instruction to the graphic
frame. If you miss this target, the
instruction is indicated below the AND
box.
6.19
Alternative to pasting per drag-and-
drop: Highlight the frame and double-
click on the assign icon.

Now, the only thing still missing in your
AND function is addressing:

Click on ??.7?. Enter the symbolic name
"Key_1" (with quotation marks). Or,
click on the question mark, right click
to select Insert symbol and then insert
a name from the list.

Enter “Key_2” for the input of the AND
box.

Assign the name "Green_Light” to the
function.
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Getting started with programming

=4 STEP 7 Lite - Getting Started - [0B1:Main_Program - Project]
ﬁf\\a Edit “iew |nset Test QOptions ‘Window Help

| S H|v (W [ SA [ g mmH [ oo |2

E [2] C@nitrol the CPU Online ¥

LT E

DB1:Main_Frogram - Project

| [ -

SIEMI NS 5| (deress pechration HName Type Start value Comment
) et 0.0temp OB EW CLASS EVTE |Bits 0-3 = 1 (Coming evd
1.0 temp OB1_SCAN_L BVTE 1(Cold restart scan 1 of
Wy Hardware ) 2.0 temp OB1_PRICRITY BVTE 1 (Priarity of 1 i lowest
&5 Symbol table 2.0 kemp OB1_OB_NUMER BVTE 1 (Cwgarization black 1,
14 MoritorModify 1]

2 Cross-references
£ Project documentation
Comment
% Program @
{3 0B1:Main_Program 1

T': AND Function

ey 1"
a2

0BL: Wain_Program Pericdically Processed Main Program

“Green_Light"
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The AND function program is
completed.

After no more symbols are displayed in
red color, click on the disk icon to save
your entries.

Not only your entries in OB1 will be
saved, but rather all project elements.

When you select Edit > Apply, your
entries (this is always the content of
the active window) are saved to a
temporary file.

This file saving method is
recommended in case you want to
undo changes later. After entering only
data, you are prompted to save your
changes when you close the project.

Symbols are displayed in red color, for example, if
not included in the symbols table or if a syntax
error has occurred.

In this case, you cannot save your entries and
the lower section of the editor displays a plain
text message informing you of appropriate
procedures.



£, STEP 7 Lite - Getling Started - [0B1:Main_Program - Project]

] 21 <ortrol the cPU onine ¥

&5 Symbol table
1) Moritar/Modify |

{7f Fle Edt View Inset Test DOptions Window Hep
& H| v W sl b | S = i
0B1:Main_Progiam - Project

1 (<1 fomparator
21 faa] Qonverter

Declration | Name Type
0a]tery OB EV_CLASE erTE

Slooumsoned @ [l £
i i 5 10 e o1 _Scan 1 ma
4 Hardware 20 temp OB PRIORITY BrTe

v i @t

N7 || g @& |-

o & 5@

) Bits 47 = 1 (Event.
f OB 1), (Sean 2-m 2F C

rE How to program OR functions

in FBD

2 Crosseferences
£35 Project documentation
4 Program

£ 0B1:Main_Pragram Q1

= ] e cal
# (5] s

@ () reger fet

1 2] Qosting-poink fet,

= () fove

%1 ) Program congel |

%1 (@) ShiftRotate
4 Status bits

% (@) Timers

@ (= Wordlogic

Highlight network 1.

Insert a new network.

&) Multiple instances

This action can also be performed via
icon in the toolbar and with right-click
or CTRL+R.

Orline-cPU

A {7f BlockEdior / {5 Properties Ca

|

S pmmSeS e w

%, STEP 7 Lite - Getting Started - [0B1:Main_Program -
£7f Fle Edt Yiew [nsett Iest Options Window Help

= Hiv Wi | SR @ ?

| (BT e ey Al OB1-Main_Program - Project

Project]

SIEMENS ) ([t oedraton reme

) etty tntes = 0.0]temp oB1_EV_CLASS
"l e by 10 temp oB1_SCAN_L
W) Hardware 2.0/ temp QE1_PRIGRITY
2] Symbol table 5.0 tamp OE1_OB_NUMER:

2 Monitor modify 1]

BYTE
BYTE
BVTE
BVTE

v it

Start walue

Again, highlight the input area.

K2 || o e - || {Ef2

Comment

L (Pricrity of 1 is lowest)
1 (Organization block 1, CBL)

v a

5 ‘Coming event), Bits 47 = 1 (Efkrt
1 (Cold restart scan L of OB 11,3 (Sean 2l ©

Insert an OR function and an assign
instruction.

I Crossreferences
§Pm]ect documentation 0Bl: Main_Program Feriodically Processes
¥ Program ]

% 0B1:Main_Frogram Q)

Commant:

Network 1: AND Function
Comment:

“Green_Light"

=

“Red_Light"

Only addressing is still missing. Enter a
name as shown in the left figure. Save
your entries.

Assign distinctive short-names to your circuits to
make it easier to scroll through large programs
via scroll bar on the right side of the view. These
names are displayed when you scroll the view.
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€ ite - Getting Started - [B1:Main_Program - Project [o15]
R B How to program memory

SHV(#adhd SQ o ? v nimt | K2 ||[alar . .
0o v s v functions in FBD

address  Declaration Name Type Start value Commert, - lew netwiark
57 Getting strted @ 0.0]temp. ©BIEV_CLASS BITE Bils -3 = 1 (Coming svent), Bits 47 = 1 (Evant (2 Bit logic

s - 10 ke OB1_ECAN_L erte 1 (Cold vestant se3n 1 oF OB 1), 3 (Sean 2-n oF C < Comparator
By rerdare 20/t osipmony forre L rrty of s omes) s Convarter
& Symbol table

s T e e | |+ 2 cane Highlight network 2. Insert an

: bt s
X crossreaeecs L additional network.
&5 Praject documenkation gy

Clment: # [2&) Floating-point Fct.
¥ Program Ll = [A] Move

0L+ Main_Progras Pariodically Procezsed Nain Progran =

£ 0BL:Main_Program @ | || Network 1 : AND Function (3] Program contral
ment: (E2] shiftfRotate

: 2 s Again, highlight the input area.
- [ —— " B memararcs

Network 2: OR Function

Comment

ey 3 = "Red_Light"
ey 4" -

R (Sat, Rasat) Memory fnction

Online-CPU' A 7% Block Editor roperties
25 s

In the instruction list, go to Bit logic

Address Declaration Mame Type Start value Comment -
01| bermp OBL_EV CLASS BVTE Bits 0-3 = 1 {Coming ewent), Bits 4-7 = 1 (Event d I t S R I t
1.0 temp OE1_SCAM_L BYTE 1 (Cold restart scan 1 of OB 1), 3 (Scan 2=n of ¢ a n se ec e e me n .
2 temp OE1_PRIORITY BYTE 1 (Priority of 1is lowest]
30 temp ‘OB1_CB_MNUMER EYTE 1 (Organization black 1, O&1) -

_ ' - | t the el t

0B1: Main_Program Periodically Processed Main Prog
Comment:

Hetwork 1: AND Function

Comment:

ey 1" "gresn_Light"
6.22 a -

Network 2: O Function

= — Set "Automatic_On”,

i & — Reset "Manual_On”,
ey 3" j Light"

(28] D call
. (Set, Reset) Memory Function

Enter following symbolic names:

&) Ampe — Set/Reset memory function
] Integer fet. .
a1 Flostrgrpant s, "Automatic_Mode .
(] Mave

[3rf Program control
(5] ShiftReotate

[a2] Status bits

(@] Timers

(2] word logic

6] Multiple instances

{rutomatic pods" )

"automatic_on"
"Manual_on"

EEEEEEEEEEEE

Save your entries via File > Save.
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a1
iy _2"

In.1
In.z

Block editor

LAD/FBD
Layaouk:

Address field width:
Display:

Selected element:

Status Fulfilled:

Status not fulfilled:

DIM A4 Partrait s
24

2-dimensional 2

_— - |
| -

How to adapt the
programming interface

The STEP 7 Lite menu commands
allow you to customize your program-
ming interface.

Menu View — Examples:

For symbolic addressing in FBD:
Enable View > Display with > Sym-
bolic Representation

For absolute addressing in LAD:
Disable View > Display with > Sym-
bolic Representation

Changing the programming language
View > LAD/FBD/STL

Menu Options > Settings — Examples:

Line break in symbolic addressing,
between the 10th and 24th character:
Options > Settings > LAD/FBD

> Address field width

Changing the view colors:
Options > Settings > LAD/FBD
> Selected element

Close the block via Windows icon
Close.

Especially the Options menu offers many
options for the customization of colors, fonts,
address field width etc. in STEP 7 Lite.

Getting Started STEP 7 Lite A5E00293886-01

6.23



Getting started with programming

Displaying cross-references

Jumps to location

Filters address

filters

Displays cross-references
for an address

Libraries

. STEP 7 Lite - Getting Started - [C ross-references - ’roject]
2% File Edit Miew Insert Options

Prait ct

B Taete ALeu VAN  Cross references -

5] Getting Started
Wy Hardware

Edit Fiter. .

G0 to Location

Cross-teference far address

Bit logic
Comparator

= Symbol table

i MorikorModiy Address /| Symbel | Block
XE T0.1 Key_L 0B 1

235 Project [l mentation 10.2 Key_2 0B 1
£ Progran Q|| 102 EEL?' SE 1
: . e

3 0B A il

CLICKJ ]

Block Sym.
ain_Program
Main_Program
Main_Program
Main_Program
Main_Prodram
Main_Program
Wain_Program
Main_Program
Main_Program
Main_Program

Metwork Row Access Language Ine
FED
FBD'
FED
FBD
FED
FBD
FED
FED
FED
FED

#utomatic_On 0B 1
Manual_on 081
Green_Light 0B 1
Red_Light 0B 1
iutomatic_Mode 0B 1
Automatic_Mode 0B 1

fffr@P@OomD
DUl PRPOOE R

Pidltiple instances

6.24

kil | i
3 Cross-referencelist /Il _Addresses used ;. L Program structure /  WEHRunt g ok 7
= Abs hw 3 Ins

L9257, Online-CPU

Press F1 to get help,

Displays call hierarchy of
blocks

Displays assignment of used bits, bytes,
timers and counters

Lists used addresses and jumps to
location

Use the views “Cross-reference list”,
“Addresses used” and “Program
structure” to get an overview of how to
use addresses, memory areas, blocks
etc.

You can get to the cross-references by
double-clicking the “Cross-references”
symbol in the project window.
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Using function blocks

Generating and opening
function blocks (FB)

Function blocks are used in function
programming if you have to save inter-
mediate results or operating settings
and operating modes until the next call.
For this reason, they are also referred
to as "Blocks with memory”.

In your sample project, you program
function block FB1 under the symbolic
name "Engine”.

Use the programming language you
used in programming OB1.

Your "Getting Started” project should
contain a copy of the symbol table
before you continue with this chapter
(see Page|5.5).
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The dialog box for
project selection is opened.

STEF 7 Lite (

Last processed |File system | [Memory Card

Falder
= SkGetting Started k7p  DiiStep? &
Elg—_lfirst_steps_stl.k?p C:\SiemensiS7LitelExamplesiEnglish
Elg—_lfirst_steps_lad.k?p C:\SiemensiS7LitelExamplesiEnglish

File name:

=2 STEP 7 Li
File Edit Miew

- Getting Started
(8 Dptions  Window Help

Clrl+H

| m|v

B8 121 Control the cF

3 | % Bz WX | o o | EESTI2IIBHIDGAA v #4§ @t |

SIEMENS

Zj Getting Started
Il] Hardware @
@j Syrnbol kable
ﬁ Manitor/Madify
J{ Cross-references
g Project documentation

The dialog box for creating
new blocks is opened.

W

Hew block HE
Murmber

Qrganization block, OBL: CYCL_EXC -

* Function block =1
Eunction e O
Data black. DER | 1 = | Global DB -
Data bype unf 1

Elock properties

Symbal; Engine

Symbol Comment: Engine coftral

Created in Language: [LAD ]

STL
Black header propertiediit

Mame (Header)

v Multiple instancs compliant

Yersion (Header): 1.0

Farmily: Authar:

Ok I Cancel

The block is inserted and
opened immediately.

=, STEP 7 Lite - Gelting Started - [FB1:Engine - Project]
f Fle Edi View Insert st T

J@H\‘/”ﬁ.}“ﬁ.m\g@r;{, ‘7.7( | o o eES7RIBHIODAA T mi b | KD

{3 12] Contral the CPU Online

FB1:Engine - Project

Start valus Comment -

%3] Getting Started
Wy Hardware
Symbol table:
2 Monitor Mo dify

in_out
stat

temp

K]

J Crossreferences
Title:

FB1: Engine

45 Project documentation

F program o
{8 FB1:Engine 4
{} oB1:Main_Program 21

If required, open STEP 7 Lite.

In the Open project dialog, double-
click on "Getting started” to open the
project.

In your project window, click on
Program.

Select menu command Insert > Block,
or right-click to open the pop-up menu
and select the New > Block command.

Highlight Function block. 73

Select the language you want to use for
your programming in the Created in
language drop-down list box.

Confirm with OK.

The new block is inserted and opened
immediately in your project window.
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Using function blocks

How to edit the variable
declaration table

We are going to show you how to
program a function block that uses two
data blocks to monitor and control a
petrol and a diesel engine.

All "engine-specific” signals, namely the
block parameters, are transferred
between the organization block and the

Project window Code section Variable declaration function block. .
Thus, they must be declared in the
table ! .
variable declaration table as I/O para-

meters (Declaration "in” and "out”). This
defines the "Interface” for calling your
function block in the program.

Libraries

5! TEP 7 Lite - Getting Started - [FB1:Engine - Project]
ffFile Edt Yiew lnset Test Options “Window Help

2% IR T N

Ao Al FB1:Engine - Projcct

GESTI21BHODOAA v dhi bt

Bl Hrowre e angine o satch off

Symbol table: = sctuallspesd T o % (1] Counter

28l Moritor iy 40/out Enginf on BocL FaLsE 2 E ?Bﬂa“

D Crosseferences a.1jout PresetfSpeed_Reached |BOGL FALSE ® 5] Jumps . . . .

o foamematn e Next thing to do is to edit the variable
Do G = i o declaration table of the FB, before you
T} OB1:Main_Program 4 | | e Shitrotats ’

) () Status bits H H H
2 @ continue to program instruction
on Enfine, Normally Classd and Normally Gp=n Contacts z z mi“zimmg elemen tS

=l
\ Project (SRTTX<INY A {74 BlockEdior § {5 Properties
25 S £
\
Com ) e comen Enter the variables as shown in the
0.0 in Switch_0n FALSE Switch on engine = f| g ure.
0.4in Switch_OFFL BOOL FALSE Switch off engine
02in Failure BOOL FALSE Engine failure, causes the engine ko switch off
20in Aictual_Speed INT 0 fichual engire speed . .
40/ out Engine_On BOOL FALSE Engine is switched on Click on a cell and enter a reSpeCtlve
41| out Preset_Speed_Reached |BOOL FALSE Preset speed reached name an d comment as s h own in th e
in_out X
6.0 shat Preset_Speed NT 1500 [Requested engire speed Y fi gure.
e CLICK I

e Select Type from Elementary types
via the pop-up menu by right-clicking
the mouse button.

Press Return to move the cursor to the
next column or to insert a new row.
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1. Editing the variable declaration table
Only letters, numeral and underscore can be
used to name block parameters in the variable
declaration table.

2. Help on the variable declaration table?
More information is found via F1 > Content >
Programming blocks > Creating logic blocks
and Editing the variable declaration table.

3. Tips on the chapters below

In the following chapters you are going to
program an ON/OFF switching circuit and a
speed monitoring circuit.

When is the engine switched on and off?
- The engine is switched on if the signal status of
variable #Switch_On is ”1” AND if the signal
status of variable "Automatic_Mode” is "0”.
- The engine is switched off if the signal status of
variable #Switch_Off is ”1” OR if the signal
status of variable #Failure is "0”. 7.5

How does the comparator monitor the speed of

the engine?

- The comparator compares the variables
#Actual_Speed and #Preset_Speed.
The result is written to variable
#Preset_Speed_Reached (Signal status "1”).

Depending on the language you have
selected for programming your OB 1,
go to:

Pagel 7.6/to 7.7, for LAD

Page|7.8|to 7.9, for STL

Page 7.10 to 7.11, for FBD.
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Using function blocks

Programming FBs in LAD

Hamne Start value
00| Switch_On Bo0L FALSE Sui
0.1]in Switch_Off1 BOOL FALSE

0.2/in Failure BOGL FALSE

B Mew network.
= 2] Bkt logic
Al
Al
I ~|NOT-
o =0
o (#)-

ed and Normally Open Contact

0 ()
I rs
I sr
> ()
o (P
< ~(SAVE)
T e
T ros
* (<] Comparator
+ 5 Converter
+ £ Counter
+ 5B DB cal
G

* [z Inkeger fct,
# (28] Floating-point fct,
* [ Move
# (3] Program control
# (5] shift/Rotate
* aie] Status bits
* (@] Timers
+ (2] word logic
TR
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How to program an engine
On/Off circuit

Highlight network 1. Open Libraries >
Commands. Insert a series circuit
consisting of a NO contact, NC contact
and an SR flip-flop.

Next, highlight the circuit upstream in
front of the R input and insert another
NO contact.

Highlight the left circuit upstream of the
NO contact. Insert a NC contact in
parallel to the NO contact.



tting Started - [FB1:Engine - Project]
Insert Test Opfions Window Help

Check whether the symbolic represen-

4D CHis
sIL Chis2
EBD CHis3

BES7 321-1BHO0-04: +  dhi dht (34

1k #

Suitch_On =
Suitzh_off ool
Falure FALSE

FALSE Suitch on engine

® Block Editor
Froperties

epiesentation Clikd

the engine to switch off

[ >

|

tation is enabled.

FBL: Engine Title:

Comment:

: Switching on Engine, Normally Closed and Normally Open Contacts

Highlight all ??.?. Enter the respective
name in your variable declaration table
(# is assigned automatically).

Assign the symbolic name "Automa-

#Engine_in
#5witch_On "Automatic_Mode" 63
{ f 1./} F
#Switch_0ff
{ f
#Failure
1./}

tic_Mode” to the NC contact of the
series circuit.

FB1:Engine -

Project
00 Swizh_on = FaLsE
01n Switch_OF ool FaLse
E Failure BOGL FaLSE
20n Achudl_Speed T o
40 out Engine_on oL FALSE
41 out Presel_Speed Reached [EOGL FALSE

Susitch on engine -
Susitch off engine

Engine failure, causes the engine to switch off

Achual engine speed

Engine is switched on

Preset speed reached

Libraries

B New netwark
¥ ] Bt logic
= (4] Comparator
T Eat
T neT
Fera

[T GEL

in_out e
| 60 stat Presel Speed ™7 1500 Reauedted ruee | 7
4 v

—

Network 2 Monitoring the Speed J

Camment :

GE_T #Presst_Speed_Reached
—

#Actual _spe=d o

#Preset_spead o

[ LET
T ea D
T nE_D
FeTo
T LTD
[ cED
T LED
T ea
T nER
[ eTr
T LTR
[ GER
T LER
¥ [agl Converter
# fx1] Counter

¥ (o8] DB call

# (5] Jumps

¥ 21 Integer fet.
# 2] Floating-poinit
¥ () Mave

# (3] Program control

How to program a speed
monitoring circuit

Insert a new network and highlight the
circuit.

In the command library, select
Comparator and insert GE_I. Also
insert a coil in this circuit.

Again, highlight the question marks.

Assign a name to the coil and to the
comparator according to the variable
declaration table.

Fik,

Save your entries.

Local block variables are identified by # and they
apply only in the block. Global variables are in
quotation marks, they are defined in the symbol
table and apply to the entire program. The signal
status "Automatic_Mode” is specified in OB1
(Network 3, compare Page 6-10) by another RS
element and is now queried in FB1.

More information is found via F1 > Content >
Programming blocks > Creating logic blocks
and Editing LAD elements.
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Using function blocks

Programming FBs in STL

How to program an engine
On/Off circuit

, Z Check whether the symbolic
L G Pean: - miat |z representation is enabled.

[Bits 0-3 = 1 (Coming event), Bis 47 = 1 (Event
| |1 (Cold restart sesn 1 of OB 1), 3 (Scsn 2-n of €

53] Getting Sta

FE1l: Engine Title:
First_Steps_STL

Comment:
A #Swi tch_on
AN "Automatic_Mode"
i ﬁgﬂ?%ﬂﬁzg?f Enter these STL instructions in
aM #F
R #Engine on network 1.
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How to program speed
monitoring

FBl: Engine Title:
First_Steps_STL

Network 1 : Switching on Engine
Comment:

) #3w tch_on

A "Automatic Made”
5 #Engine_on

0 #5wn kch_OFF

ON  #Failurs

3 #Engine_in

HEErark 2: Momitaring the Speed

#hctual _Speed
#Preset_spead

- #Ppeset_Speed_Reached

o Insert a new network. Enter these STL
instructions.

Save your entries.

Local block variables are identified by a

# character and apply to this block only. Global

variables are in quotation marks, and are defined

in the symbol table and apply to the entire 7.9
program. The signal status "Automatic_Mode” is

specified in OB1 (Network 3, compare Page|6-16)

by another RS element and is now queried in

FB1.

More information is found via F1 > Content >
Programming blocks > Creating logic blocks
and Editing STL statements.
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Using function blocks

Programming FBs in FBD

Librarie:

How to program an engine

Address Declaration Type Start valus B ew network.

ot soa ot On/Off circuit

aslou Insert an SR function in network 1 via
N olat Praset_Speed fros 1500 command |ibrary_
FB1: Engine Title:

First_Steps_fOB

Assign an AND box to input S (Set) and
o Tner and an OR box to input R (Reset).

ward logic
Multiple instances|

Getting Started STEP 7 Lite ASE00293886-01



%, STEP 7 Lite - Getting Started - [FB1:Engine - Project] CheCk Whether the Symb0|iC

5 Fie Edit W) Inseit Test Options Window Help
EE : ? ] representation is enabled.

sIL
Bercontalt o £op

Stvale | Comment
® Block Edtor jich_on raLsE Swich on angine
S5 Getting Sta . 2
o Propertes ¥ FaLse swich offengine
| Hardwar FaLsE Engine faiure, causes the engine to switch off

S . = s Highlight all ??.?. Enter the respective
name in your variable declaration table
(# is assigned automatically)..

15 N network
(2 it logic

51 4] Comparator
1 82 Converter

o el camer G Use the symbolic name

5] Getting Started ]
Wy Hardware L]
& Symbol table
1) MeritorjModity

% () DB cal

S smmeie, ”"Automatic_Mode” to address an AND

& program Q 60 stat Preset_Speed v

ol | 1 4 = o function input.

FBL: Engine Title: | # (2 shirotate ” . N
2 g s Invert the "Automatic_Mode” and

& e rataees #Failure inputs, using a corresponding
symbol from the toolbar.

4} OB1Main_Program &1

How to program a speed
monitoring circuit

£, STEP 7 Lite - Getting Started - [FB1:Engine - Project]
£5f Fle Edt View lnsen Jest Options Window Help -la

S v [@aas I35 1 oo | < aia | w = Insert a new network. Highlight the
circuit.

B New network.
1 (&) Bit logic

1] 121 <ortral the CPU Cniine ¥

5] etting Starked 5]
L)

Typs
BooL FALSE

01 BooL FALsE = (<) Comparatar
E_;:ardbw\‘a;em 02 in BOGL FALSE. switch off £ eQr
el bable 20/in NT H
e o5 - In the command library, go to
M cross-references 41 out Preset_Speed_Reached  BOGL FALSE
irond et - Comparator and enter GE_I. Address
£ Program Q 6.0 stat Preset_Speed T 1500 - -

the inputs with a name from the varia-
ble declaration table.

1} OBL:Main_Program Q1

w

#ctual_speed

#Preset_speed

; Assign an assign function to the
- & o comparator. Use a name from the

o o variable declaration table to address
# (2] Integer fet, . .
: this function.

Save your entries.

Local block variables identified by a # character
apply to this block only. Global variables are in
quotation marks, and are defined in the symbol
table and apply to the entire program. The signal
status "Automatic_Mode” is specified in OB1
(Network 3, compare Page|6-22) by another RS
element and is now queried in FB1.

More information is found via F1 > Content >
Programming blocks > Creating logic blocks
and Editing FBD elements.
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Using function blocks

Generating instance DBs and
modifying actual values

Inserting data blocks

To be able to program the call (CALL)
of FB1 in OB1 later, you must generate
a corresponding data block.

The FB is to control or monitor a petrol
or diesel engine. The different speed
setpoint values for the engines are
stored in two separate DBs, that is, by
modifying the respective actual value
(#Preset_Speed).

You reduce your effort by programming
a single, central FB.
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New block

Organization block

Function black.

Murnber

Symbol Comment:

reated in Language:
Block headet propetties
MNare (Header)

Family;

Function

+ Datablock DB 1 SR
Data type |

lack

Symbal: Petral

[Data For petrol engine

“ersion (Header): 1.0
Author;

QK ancel

r( The block is inserted.

4 STEP 7 Lite - Gelting Started - [DB1:Petrol - Praject]
Fie Ecit I8 Ins=tt Test Options Window Help

B IOt C B by ieo Denview
g“’a’“ 85 Project Documentation

ardware
(2o )

Cirlst+T

CrblteT

=8 z
Declaration Yiew
B 21 controlt
® Elock Editar Name. Type Start value
Properties Switch_on oL FALSE
%] Gettng Sta Suitch_OFF B00L FaLSE
Wy rarduar - Display'with " JRatre 800l FaLsE
& symbolt Actusl_Speed T o
2l Morikor 1 Engine_on BOOL FALSE
X crossre Preset_Speed Reached BOOL FALSE
Praset_Spesd T 1500

spes
FALSE Engine is swiched on

( J_JRequested engine speed

4=f Fle Edit View Insert Tesl [ dow_Hel

BES7 321-1BHONIAA ~  dhi #t

= H| v W | SR X o
[ 12) Controlthe cPU Onine 3 | |[EFEVTXE
P Address

Hame. Type Start value
Swich_on BOOL FALSE
Swich_of BOOL FALSE
EOOL FaLsE
T o

BOOL FALSE

5] Getting Starked
M Harcware
] symbol table
2 MonikarModify

Presst_ Speed Reached |BOOL FaLse
Prasel_speed mr 1500

2 Cross-references
5 Project documentation

{1 oBL:Main Pregram 23

—0

Right-click on the project window to
open the pop-up menu. Select New >
Block. The New block dialog pops up.

Highlight Data block. Enter FB1 as the
assigned function block (as shown in
the figure).

Confirm with OK. DB1 is inserted in
your "Getting Started” project and
opened immediately.

Enable Data view. You can edit the DB
only in this view.

For the petrol engine, verify that you
have entered the value "1500” in the
Start value column.

Analogously, insert a DB2 "Diesel”.

For the diesel engine, enter
the Start value "1200” in the column.
Save your entries.

To program the FB call in OB1 in your
selected programming language,
continue at the respective chapter
relating to LAD, FBD or STL.

By setting the actual values you have completed

your preparations for controlling two engines with
the help of a single function block. You only have
to generate the respective data blocks to control

further engines.

More information is found via F1 > Content >
Programming blocks > Creating data blocks.
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Using function blocks

Programming block calls
in LAD

The entire function block program will
be ineffective unless it is called in OB1.
To control both engines, one DB is
used per FB call.

0B1:Main_Progiam - Project

£ (2] Contral the: CPL Online: %

“ Open OB1 and insert network 4.

SIEMENS IS0 |[pdress  TDeclaration Mame Type Start value Camrnent
0.0]k OB1_EV_CLASS BYTE Bits 0-3 = 1 [ ], Bi
] Getting Started [ = —= = (Coming even), i
ol Hord o 1.0 temp OB1_SCAN_L E: 1(Cold restart scan 1 of OB 1,
| Hardyare: 2.0 temp OB1_PRIORITY TE A N 1 (Priority of 1 is lowest)
Symbol table 3.0 temp OB 1_OB_HUMER, EVTE 1 (Organization black 1, OB
4
1] Monitar fModify 4

M Cross-references

e R R / Drag FB1 from the project window to

A esed 8 | e network 4. All engine-specific variables
[| DE1;Petral >4 277 . .

A will be displayed.
T% SETiMa Froarsie G FE1 'Engine ( i tch_n k Engine_onfa .

Swi keh_0FF Praset_Speed Reachedp,, |

—fFailure

— CL'CK.I a Click on ??.? The symbol selection list
pops up.
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Metwork 4 : switching on the Petrol Engine

Comment

In this symbol selection list, select data

[ "Petrol” \

" Zwitch_on_PE"—|
" S teh_0ff_FE"—

"PE_Failure"—

"PE_Actual_Spead” O

\ "Engine” ]

block "Petrol”.

PPE_On"

|, PE_Freset_peed_feach

Again, address all other FB parame-
ters, using corresponding symbolic
names.

p
N

The call for the diesel
engine is still missing

0B1:Main_Progiam -

[ 121 Cortral the CPU Online ¥

Project

Address Declaration

SIEMENS )

15
0.0]k

55 Getting Started Q@ i .Emp

0 temp

ﬂ Hardware @ 2.0 temp

Symbol table 3.0 temp

Mame Ve
OB1_EV_CLASS BYTE
OB1_SCAN_L BVTE
OB1_PRIORITY BYTE
OB1_OB_NUMER: BVTE

T T e ——
Bits 0-3 = 1 (Coming event), Bif

1 (Cold restart scan 1 of OB 1,
1 (Priority of 1 is lowest)
1 (Organization black. 1, OE1)

Engine-specific 1/O variables (Declara-
tion ”in” and “out”) are displayed in FB
"Engine”.

All variable are assigned a "PE_xxx"
signal for the petrol engine.

Insert network 5. Again, drag FB1 from
the project window to the network.
Analogously, program the call of FB
"Engine” (FB1) with DB "Diesel” (DB2).

1) Monitar Madify
J cross-references

458 Project documentation Commenty

Hetwork 4 : Switching on the Petrol Erfine

"DE_Failure'—

"DE_Actual _Speed"

& Progem ° Assign all variables a "DE_xxx" signal
[F) DB2:Diesel ] patral® K )
i oBupatal % for the diesel engine.
i} FEL:Engine B . " "
5w tch_On_PE"— B PE_On'
- . g :ijEJr-ese .
{_t FB1:Engine Save your entries and close the block.
"PE_Actual _Speed’ O
Hetwork 5: switching on the Diesel Engine
Comment:
"Diesel"”
\ TEngine" ’
" Swi tch_On_DE"— P"DE_On"
" Switch_0Ff_DE"— j::DEJ’r‘EsE

When you create program structures which
include OBs, FBs and DBs, you must declare the
call of the lower level block (e.g. FB1) in the
higher level block (e.g. OB1). This procedure is
always the same. In the symbol table, you can
also assign symbolic names to the different
blocks (e.g. FB1 "Engine” and DB1 "Petrol”).

You can always print block programs via File >
Print. Further information on printing is found via
F1 > Content > Printing project
documentation.
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Using function blocks

Programming block calls
in STL

A function block program will be
ineffective unless it is called in OB1. To
control both engines, one DB is used
per FB call.

=4 STEP 7 Lite - Getting Started - [0B1:Main_Program - Project]
54 Fle Edt Yiew lnsett Iest Options Window Help

Open OB1. Insert network 4.

Address Declaration Mame Type Start walue Comment
j Getting Started @ 0.0[temp OB1_EY_CLASS BYTE Bits 0-3 = 1 (Coming event), Bits 4-
ll a 1.0 temp OEB1_SCAN_L BYTE 1(Cold restart scan 1 of OB 1), 3 (5]
| Hardware L 2.0 temp OE1_PRIORITY EYTE 1 (Priority of 1 iz lowest)
Symbol table 20/ tamp OB1_OB_MUMER BYTE 1 (Orgsnizstion black 1, OB1)
k) Monitor/Madify 4 | tL) H ” 9 ”
pr . — Declare ”Engine”, ”Petrol” in the
45 Praject documentation "Et"‘"_ 3: (56T, H H H
o all = CALL instruction. Confirm the entry
g L £ smnstic b with Return. All engine-specific variable
DE1L:Petrol A "Manuzl_0n" .
Chestene 9 oy Y are displayed.
Wetwork 4): Switching §n the Petro] Engine

{4 OB1:Main_Program @ [ || T ree-o-T
Comment :

T R e Right click next to ”:=" to open the pop-
Hierd e .
Actuzl _Spead PE_Pieset_Speed_Reacfed (5.1 up menu Select the Insert SymbOl

command. The symbol selection list
pops up.

gine_n .
Prasst_spesd_Reached:

Switch_Off_DE 115
Switch_0ff_PE 111
Switch_On_DE

Getting Started STEP 7 Lite ASE00293886-01



Wetwork 4): owitching on the Fetral Engine Again, address all other FB parameters,

Cerm=ies | using corresponding symbolic names.
(CJ’(L'T I"Eng'ine" , "F'etr'o'D —
o oW TCh_UN, . I . .
swikch DFf s tch OFF_pE! Engine-specific variables (Declaration
allure rallure ”: ” ” ” H H
fotual Speed E-pc fual _Speed” in” and "out”) are displayed in FB
Freset_Speed Reached i="PE_Preset_Speed_Reached" » E ng | n e” .
All variables are assigned a "PE_xxx”
The caI_I for_the _dle_sel engine signal for the petrol engine.
is still missing.
Y
STEP?Lile-Eelling Started - [DB1-Main_Program - Project] e Ana|OgOUS|y, insert network 5 and
Ele Edt Yiew lnseit Test Opfions Window Help I » . »
(O Easr 39 imax e STl E)rggrarlw FB "Engine” (FB1) to call DB
- Diesel” (DB2).
Address Declaration Mame Type Stark walue Comment
" 0.0]temp OB1_H)_CLASS BVTE Bits 0-3 = 1 (Caming ev . . " "
Sﬂilele;:.:: j::ed : 10 emp oBLaAn_L BiTE IECuIdrextirl s:?mr All variables are ass|gned a "DE_xxx
2.0 temy OB1_FARIORITY BYTE 1 (Priority of 1 is lowest . . .
| Symbol table 20 tems 0B1_gE_NUMER EVTE l[Orgar\Tzal\on b\oci« 1 Slgnal fOr the d|ese| eng'ne

20 Manitor/ModiFy 4|
J Cross-references

Network 3: (56T, Reset) Mefory Instructions

£35 Project documentation .
& progan ol e Save your entries and close the block.
[5) DB2:Dissel >a A "Automatic_On"
s "Automatic_Mode'
(5] DB1:Petral <] A "Manual _0n"
EI-FEI‘Eng\ne >SI R "Automatic_Mode"
£ 051:Msin_Frogram @ rz::':::"rtk 4 : Switching on thf Petral Engine
CALL “"Emgine" , "Petrfl"
Switch_i " Switch_On_PE"
Switch_Off if' Switch _Off_FE"
Fa1l H _Failure”
Actual Spesd sF'PE_Actual Speed”
Engine_0n sE'PE_On"
Preszst_Spesd_Feached:f'PE_Presst_Speed_Reached"

Dissa] Engine

ch_Om_DE"
itch_Off_DE"
_Failure”
Jnacgua'l _speed"

Switch_0ff
Failure

Engine_On

X Zon
Preset_Speed_Reache Preszet_Speed_Reached"

When you create program structures which
include OBs, FBs and DBs, you must declare the
call of the lower level block (e.g. FB1) in the
higher level block (e.g. OB1). This procedure is
always the same. In the symbol table, you can
also assign symbolic names to the different
blocks (e.g. FB1 "Engine” and DB1 "Petrol”).

You can always print block programs via File >
Print. Further information on printing is found via
F1 > Content > Printing project
documentation.
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Using function blocks

Programming block calls
in FBD

A function block program will be
ineffective unless it is called in OB1.
To control both engines, one DB is
used per FB call.

~ ., STEP 7 Lite - Getting Started - [DB1-Main_Program - Project] ‘ Open OB1 . |nsert network 4
£5f Fle Edit View lmset Test Options Window Help

@ Hv [ Wads S& tmmd | oo |7 Datar (W[ || BB EE =

el e T SR Al OB 1:Main_Pragram - Project

m Address | Declaration  Mams Type Startviue | Commant -
Oo]tern cB1EV_CLass BYTE Bit 0-3 = 1 (Coming svent), Bils 47 = 1 (Event
5] Getting Started @ LS == (Coming event), !

Y Hordiro ® e BT T I Draq&d FB1 f th iect
E:fg Symbol table : 30 termp 0B1.0B_NMBR BYTE 1 (Organization black 1, GB1) ,Ll ra g ro p rom e p rOJ ec

x| MonitorfModif 4 : . d

3 Gomsnetroncs window to network 4. All engine-

38 Project documentation Metwork 3: SR (Set, Reset) Memory Funchion . . . .

= brogr specific variables will be displayed.

o]
[ DB2:Diesel a “Aurtomatic Mok
DB1Petral il

4} FBL:ENgine

“hutomatic_On®

“Manual_on"

e Click on ??.? to open the symbol
; selection list.

Engine
e
. —{switch_on
. fswitch_nff el
it CLICK lched,___
. grctusl_speed eno|
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Commant

Select DB "Petrol” from the symbol

{ "Petrol” \

" Switch_dn_PE" —] Switch_0n
" 5w tch_DFF_PE" o] Suitch_0FF
"PE_Failure" = Failure

Actual_speed

"PE_ATtuz]_Speed"

\ TEngine" /
En

Ergine_on b PE_on®

"PE_Preset_Spe:
Praset_speed_teached o o re et

ENO

selection list.

Again, address all other FB
parameters, using corresponding
symbolic names.

ed_feached

Engine-specific variables (Declaration

N

(~ The call for the diesel engine ) |

is still missing.

"in” and "out”) are displayed in FB
"Engine”.

=4 STEP 7 Lite - Getting Started - [DB1:Main_Pragram -
{54 Fle Edt Yiew Inset Test Opfions Window Help

Pioject]

All variables are assigned a "PE_xxx”
signal for the petrol engine.

Insert network 5. Again, drag&drop FB

B 121 cortral the CPU Oniine ¥

| Alv (Wit [ FE| g mBH |0 |

"Engine” (FB1) from the project window
and program it to call DB "Diesel”

(DB2).

fddress|Daclrafion |Mame Thes Start value Comment
M 50]temp 0BLEV_CLASS e Bits 0-3 = 1 (Coming evet), Bis 47 = 1 (B
10 temp 0BL_SCAN_L efe 1 (old restart scan 1of OB 1, 3 (Scan 2-
y Hardware L 20 temp OB1_PRIORITY el e 1 (Priority of 15 lowest)
5] symbal table 2.0 temp OB1_OB_MUMER. el e 1 (Grganization block 1, OB1L)
21 MonikarModify

2 Crossreferences
38 Project documentation

Comment:

Network 4 : Switching on the Petrol Engine

All variables are assigned a "DE_xxx"
signal for the Diesel engine.

Save your entries and close the block.

Engine_0n g "PE_on"

"PE_Praset_spes

g Program @ "Petral"

() DBZ:Diesel ] TEngine"
; <] e
" Swbeh_On_PE" e ST

_per g ich aif
ﬂ- FE1 :Enginek_mura Praset_spesd Reachad b
loedt 0 tual _speed ENO |
n 21 Engine \
——T—

c—EN

"DE_Failure" —Failure

"DE_Actual _Speed" °C

{ TEngine" ]

" 5w tch_On_DE" —f S tch_On
"Suritch_0Ff_DE" g 501 teh OFF

tual _speed

Freset_speed Reached b

Engine_0n [ "DE_on"
UDE_Presst_Spes

END |

When you create program structures which
include OBs, FBs and DBs, you must declare
calls of a lower level block (e.g. FB1) in the
higher level block (e.g. OB1). This procedure is
always the same. In the symbol table, you can
also assign symbolic names to the different
blocks (e.g. FB1 "Engine” and DB1 "Petrol”).

You can always print block programs via File >
Print. Further information on printing is found via
F1 > Content > Printing project
documentation.
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Using
functions




Using functions

Creating and opening
functions (FCs)

Getting Started STEP 7 Lite ASE00293886-01

Functions are used if FC programming
does not require of you to save inter-
mediate results, mode settings or
operating modes until the next block
call. This is why they are also referred
to as "Blocks without memory”.

Your "Getting Started” project should
contain a copy of the symbol table
before you continue with this chapter
(see Page 5.5).



o If required, open STEP 7 Lite.

| The dialog box for project
STEF 7 Lite selection is opened.

Last processed |File system | Femony Card

Falder
s SEGetting Started k7p  D:\Step?_lite X,

E@First_steps_stl‘k7|:| C:\Siemens\S7Like\Examples\English 30,
%First_steps_lad.k?p C:\Siemens\S7Like\Examples\English - 30.

File: name

Click on "Getting started” in the Open
a project dialog to open your project.

=3 STEP 7 Lite - Getting Started
File Edit Vie

| = m [
= — Categor  Chrl+k
B 121 Control the croomITE—

SIEMENS

Zj Getting Started
Il] Hardware =)
@j Syrnbol kable
ﬁ Manitor/Madify

Click on Program in the project window.

Optionz  WWindow Help

[X) | & Bz M X | o o | BES7321-1BHO00RA - | s gt |

Select menu command Insert > Block,
or right-click to open the pop-up menu
and select New > Block.

¢ Cross-references
g Project documentation

The dialog box for creating
CLICK I new blocks is opened.

o . 8.3

New black (1] Highlight Function.

Humber
Organization block. OBL: CVCL_EXC - -
et bock B In the Created in Language box,

& Furien Fe 1 select the language you have used to
e o N - N generate your "Getting Started” project.
Data bype LT 1

Symbal: Fan|

Symbol Comment: Fanfcontrol

Created in Language: | STL ﬂ v | Rl instance campliant

Nam.a (Header) Version (Header): 1.0 e Conﬁrm with OK

Family: Author:

oK | Cancel |

The block is inserted and
opened immediately.

€5 STEP 7 Lite - Gettin
% Fle Edt View

| & B [ By gty o [ GF G| & me MO | o o [ ES721BHO00AA v i vt | K2

B 12) Contral the CPU

g Started - [FC1:Far

° The new block is inserted into the
project window and opened
immediately.

| BEE@L « T

Daclaration Hame Type Start valus Comment

%] Getting Started
By Hardware: =]
Symbol table
=
X Cross-reference
£55 Project documenfation
¥ Program
% FC1:Fan

5 DB2:Diesel

Title:

B2

Getting Started STEP 7 Lite A5E00293886-01



Getting Started STEP 7 Lite A5E00293886-01

Contrary to FBs, within a function you cannot
declare static data in the variable declaration
table.

You can refer to symbolic names from the
symbol table to program the function in the way
as you are used to.



Further information is found via F1 > Content >
Basics of desighing a program > Blocks in the
user program.
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Using functions

Programming functions

In our next example you are going to
program a timer function.

When the timer is switched, the timer
function simutaneously switches on a
fan which runs for 4 seconds after the
engine has been switched off (off
delay)

Variable declaration table

Analogous to the FB, start by declaring

the function’s /0 parameters (Declara-

Addrazs | Declaration | Marne Type Stark walue | Carrnent . ] 2 »y .
0.0 |in Engine_Con BCOOL Signal for switching on the engine 0 tIOI’] n and out ) in the Varlable deC|a
2.0|in Tirer_Function ( TIMER. ) Tirmer function used for the switch-off delay ratlon ta ble
0| aut Fan_on BOOL Signal for switching on the fan R|ght_cl|ck to open the pop_up menu
— Parameter types. Select TIMER.
Ll
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7

S_OFFOT

Flnating-poink fet.
Have
Program cortrol
shift/Rotate
Status bits
= (@] Timers
T 5_PuLse
T s_PesT
7 5007
Cloon
© ~{36)
<> --{sD}

< --(5F)
(351 Word logic

#Timer_Function
#engine_on T #ran on
— e
S5Tas QT BIp...
et o,

oo | mx [ o
32

FC1: Fan Title:
Comment:

Comment s
#Engine_in
SETR#4S
#Timer_Function

#Timer_Function
#Fan_On

[
]

FCL: Fan Title:

#Engine_on —{s EIf...
sET#as TV BDf...
3 [}

#Fan_on

How to program timer
functions in LAD

Go to Libraries > Commands >
Timers. Select element S_OFFDT and
insert it in network 1.

Insert an additional NO contact and a
coil.

For ??.?, enter the names from the
variable declaration table. These are
automatically marked with a # charac-
ter. Enter the timer constant TV
S5T#4s. Save your entries. Close the
block.

How to program timer
functions in STL

Declare the instructions as shown at
the side. Save your entries. Close the
block.

How to program timer
functions in FBD

Same as in LAD: Copy the instructions
from the library to your network, fill all
??.? and declare the timer constant.
Save your entries. Close the block.

8.7

Input parameter "#Engine_on” starts
"#Timer_Function”. On subsequent calls in OB1,
the petrol or Diesel engine parameters are assig-
ned to the function accordingly (e.g. T1 for
“PE_Follow_On").

Getting Started STEP 7 Lite A5E00293886-01



Using functions

Calling functions in OB1

FC1 is called in OB1 in the same way
as a function block. For function
parameters OB1 provides
corresponding address data for the
petrol or Diesel engine.

An address is part of a STEP 7 Lite instruction
which specifies a function the CPU uses for
processing. Addressing can be absolute or
symbolic.

Getting Started STEP 7 Lite ASE00293886-01



<3 STEP 7 Lite - Getling Started - [DB1:Main_Program - Project]
{5 Fle Edt View Inset Test Options window Help

| & H|v [ 5 s (S G0 [ 4 M ML | o o | sES7a21BHO0DAA - dhd hE | K2

= |l Cpet sy (A | OB 1:Main_Program - Project

SIEMENS

%] Getting Started

os1 scan_t ovie

B Hardware

20 iemp o pricRrry[Bvre |1 oron

st)
Symbol table 3.0/temp |or1_ce umer  Jevie |1 torganization black 1, 0B1)
5 Monitor Modify 2| |

M Crossreference: (

58 Project documenfation

AF Program L]
{CF FC1:Fan k]
[5) DB2:Diesel ] |

Hetwork J- Controlling the Fan for the Petrol Engine

Commeft:

5 DB1:Petrol ] I

4 .M Controlling the Fan for the Disssl Engine
) Comment:

This is how it looks after
programming in LAD ...

T Crazerelerenies

5 Profect documentation
= Program

00 F"PE_Fan_n"

{5 OB1:Main_Progra

“DE_on"—Engine_0n Fan_0n ["0E_Fan_on"

"DE_FelTow_on" Qiner_Function

r( .. how it looks in STL, )J

Hetwork & : Controlling the Fan for the Fetrol Engine

Comment =

Comment:

CALL "Fan"
Engine_in

... how it looks in FBD.

]

r(

2 Crossreferences
5 Project documentation
4 Program ]

{CHFCLFan

Hetwork 6 : Controlling the Fan for the Fetpg@Peng
comment:

T

g

‘aine_0n Fan_0n [ *PE_Fan_on"

| &5 0k FoliFan fer ool
T  trgfllest engine

e
Fan_0n b "DE_Fan_on"
END

“DE_on" —{Engine_0n

“DE_Follown® gTiner_Function

Opening OB1
Open the "Getting Started” project

which you have generated in LAD, FBD
or STL. Open OB1.

Insert Network 6 for the petrol engine
and Network 7 for the Diesel engine.

How to program block calls in
LAD

Drag&drop FC1 to Network 6 and Net-
work 7.

Edit all ??.? as shown.
Save and close the block.

How to program block calls in
STL

Enter the STL instructions as shown.

Save and close the block.

How to program block calls in
FBD

Drag FC1 to Network 6, petrol engine.
Drag FC1 to Network 7, Diesel engine.

Edit all ??.? as shown.
Save and close the block.
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8.10

Using functions

Getting Started STEP 7 Lite ASE00293886-01

1. Your screen differs from our screen shots?

Set symbolic programming via View > Display
with > Symbolic Representation.

2. You want to see more on-screen
information?

Enable View > Display with > Symbol
Information to obtain information on specific
network addresses.

To display several networks on-screen, disable
View > Display with > Comment and, if
required, View > Display with > Symbol
Information.

Under View > Zoom factor, you can adjust the
on-screen size of the networks.

3. You need information on the programming
languages LAD, STLL or FBD?

Further information is found via F1 > Content >
Calling Reference Helps > Language descrip-
tions and block help.

4. You do not always want to call the
function?

In our example we have programmed an absolute
function call, that is, the function is always going
to be processed. Depending on requirements for
your automation task, you can also program
conditional FC or FB calls: e.g. via enable signal
from an input or series circuit. The EN input or
ENO output of the box are both available for

programming conditional calls.



Using global
data blocks




Using global data blocks

Generating and opening
global data blocks (DBs)

You can save selected data to a shared
data block if the CPU cannot store any-
more because it has run out of internal
memory bits (memory cells).

Data of a shared DB are available to
any other block. An instance DB, on the
other hand, is assigned to a specific
function block. Its data are only
available locally in this FB (compare
Chapter 7/ How to generate instance
DBs and modify actual values).

Your "Getting Started” project should
contain a copy of the symbol table
before you continue with this chapter
(see Page|5.5).
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STEF 7 Lite

The dialog box for project
selection is opened.

Eie Edit ‘iew
| @ ||
B8 121 Control the cF

SIEMENS

Zj Getting Started
Il] Hardware
@j Syrnbol kable
ﬁ Monitor/Modify

J{ Cross-references
g Project documentation

= STEP 7 Lite - Getting Started - [DB3:5_Data - Project]
{5 Fle Edt Yiew lnseit Test Options Window Help

Open Project

B4 new Project
f

™ Creat

Last progessed |F\|e system | Werony Card |

The dialog box for creating
new blocks is opened.

Created in Language: [ -

Block header properties

| [Multiple instance complisnt

New block HE o
Hulber
Organization block ol CvoL_Exe ¥
Function block Bl 2
Function Bz
o G ok DB 3 » Global DB -
Data type DT 1 - o
Block properties |
Swymbal: S_Data
Symbol Comment: Shared data block

[ame (Header)

Family:

Version (Header):

Author:

ok |

1o

Cancel I

The block is inserted and
opened immediately.

Type start value Comment

STRUCT

ool FALSE

Wy Hardware

END_STRUCT

&5 Symbol table
1) MeritorjModify)

X Crassseferencls
£ Project documa
F program
) b3S _pat:
L FCLFan
) DB2:Diesel
) pe1Petral
hniE

=

B e

5 New netork

a1l Bitlogic
<] Comparator

(ex] Tneger fet
(28] Flaating-paink fet

(3 Wordlogic

Pragram cartral
shitfrotate
Status bits
Timers

If required, open STEP 7 Lite.

Double-click on "Getting Started” in the
Open project dialog to open your
project.

In the project window, click on
Program.

Select menu command Insert > Block,
or right-click to open the pop-up menu

and select the menu command New >

Block.

Highlight Data block.
A ”3” is written automatically to the DB
field, and "S_Data” to the Symbol field.

Here, select "Global DB”.

Confirm with OK.

The new block is inserted into the
project window and opened
immediately.
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Using global data blocks

Programming DB variables

DB3:5_Data - Project

Dreclaration Mame Type Start walue Comrent
M| skat STRUCT
stat PE_Actusl_Speed ) INT Actual speed for petrol engine
stat _ACtal_Spes IMT Actual speed For diesel engine
stat Presel_Speed_ReIche BCOL [Eoth engines have reached the preset speed
skat EMD_STRUCT

n In the Name column, enter
"PE_Actual_speed”.

Right-click to open the pop-up menu.
e Select the Type under Elementary

types > INT.

Complete the list as shown above.

Save your entries. Close the block.

Further information is found via F1 > Content >
Programming blocks > Creating data blocks.
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Downloading programs to the CPU

A0 0 & e :
o - o
Powe pp
on/o ode selecto
Progra g de e
» a . 3 N
E 0.3
' - A 4.1
S E 0.4
. ~ i
24V o :
10.2‘ T
We shall use your "Getting Started.k7p”
Power project to show you how to download
supply MPI cable the program to the PLC. Feel free to
use one of the included sample
programs instead.
Comb
connector " Next thing to do is to make some
Memory module .
preparations.
Back-up battery* Construct a test assembly
Rack
Test assembly a To test your sample program, you
Parallel circuit require a test assembly which allows

you to set inputs (e.g. with push-
buttons).

*= Not absolutely necessary
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e Perform a program check

If you decide to use your "Getting
Started” project, you should at least
have configured your hardware
(Chapter 4)| and programmed the
parallel circuit (Chapter 6).

o Perform a hardware check

Assemble your hardware and check
once again:

- Are the bus connectors plugged into
the modules?

- Are the modules attached to the
profile rail, swung down and screw-
tightened?

- Is the 220 V power supply
connected?

- Is the comb connector inserted?

- If exist, have you inserted the
backup battery and memory
module?

10.3
° Establish the Online
connection

To establish an Online connection
means to interconnect the CPU and
PG.

- Interconnect the CPU and the PG
via MPI cable.

At the CPU:

- Switch on the power supply

- Set the mode selector switch to
STOP.

At the PG:

— Switch on the master switch.

— Run STEP 7 Lite.

— Open "Getting Started.k7p” or one
of the sample projects.

Getting Started STEP 7 Lite A5E00293886-01



Downloading programs to the CPU

Going Online

BESTI2NIBHOODAA v | i tit | KD

When started, STEP 7 Lite immediately
attempts to go Online.

t The Online button must be lit in green
e color. The status bar indicates the
- Online connection status, followed by
CPU mode STOP.
If STEP7 Lite fails to connect to a
CPU, it remains Offline and the status
bar indicates the connection status
Offline.
In this case, eliminate the cause of the
Online connection failure (e.g. a cable
is not properly plugged in or the CPU is
switched off) and then click on the
Online button.
CLICEJ You can always click on this button to
— go online or offline.

aaaaaaa

eeeeee

=
Mutiph

10.4

Verify that Control the CPU Online is
indicated. If yes, the buttons on the
CPU operator panel are enabled.

Check: The status bar now displays the
actual CPU operating mode.

Try out: You can now toggle Offline
e view Project and Online view Online
CPU.

The Online CPU tab shows all blocks
of the CPU.

Icons on your project window will
indicate data inconsistency between
PG and CPU if you have not yet down-
loaded your program to the CPU.
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You can also establish Online connections and
perform tests (Chapter if you use other than
the hardware displayed on Page You merely
have to comply with 1/0 addressing conventions.

Further information on the assembly of PLC
modules is found in the
”S7-300 — Hardware and Installation” manual.

Further information on establishing online
connections is found in the Online Help via F1 >
Content > Establishing an Online Connection.
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Downloading programs to the CPU

Resetting CPU memory and
downloading the program

o

-i_-IEM.EHS e [ ’

i

I

CPL 215
|| IH'F' ' Bl ocaav
B S q
| RN
ﬁ F F [ ? }! SELECTOR
B RU r--J e
% STOP  |PMRES | —

o o A W@ n

|
o

]
o~
]
o 2 w N = o

o

~

IR

N~ o o

The CPU operator panel

Reset CPU memory prior to program
download. You can use the CPU
CPU operator panel gper?ltor ??r?elégSTEP 7 Lite or

in STEP 7 Lite irectly at the LrL.

CPU operator panel
on the CPU

CPU operating modes are also set on
the operator panel.

Due to safety reasons, however, the
STEP 7 Lite operator panel only lets
you select the operating mode set at
the CPU.
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Example:

— At the CPU: Switch is set to RUN -
At the STEP 7 Lite operator panel:
STOP instructions can be enabled.

— At the CPU: Switch is set to STOP -
At the STEP7 Lite operator panel:
RUN instructions cannot be
enabled.

In danger situations you can also
set the CPU to STOP mode via
STEP 7 Lite.

CPU memory reset at the CPU

Before you download your program to
the CPU, delete all old data and
programs on the CPU via reset
memory instruction. To do this:

CPU on.

Mode selector switch to STOP position
(if not already in STOP position). The 10.7
LED is lit in red color.

Turn the mode selector switch to MRES
position. Hold it there for at least three
seconds until the red STOP LED
flashes at a slow rate.

Release the mode selector switch.
Within three seconds, set the switch
once again to MRES position and hold
it there until the STOP LED flashes at a
fast rate.

You have now completed CPU memory
reset.
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Downloading programs to the CPU

CPU memory reset in
STEP?7 Lite

You can also choose to reset CPU
memory via STEP 7 Lite.

RUN-P

—
*’ At the CPU: Set the mode selector
] STOP position.

74 STEP 7 Lite - Getting Started
File Edit “iews |Inzert Option:  Window  Help

| @ B|v [ el [N %X | oo | EESTR

I [2] Contral the CPU Online #%

SIEMENS
Ty DIA

( 213
In STEP7 Lite: Click on the MRES
button.
LICK I
You are prompted to con-
firm your action.
10.8
& Clear / Reset sets the module to STOP and resets it.
All uzer data, as well a3 the hardware configuration will be
deleted and all connections to the module terminated.
Do vou really want to Clear / Reset?
Yes
CLICKl Confirm with YES. CPU memory is
reset.

Information on operating states is found in the
STEP 7 Lite Help via F1 > Content > Appendix
> Operating Modes.

Note:

It is of advantage to be familiar with CPU
operating modes when you program startup or
test routines for the controller, as well as for error
diagnostics.
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How to download the program
to the CPU

RUN-P

Verify that: During program download
the mode selector switches at the CPU
and in STEP 7 Lite must be set to Stop
position.

E— Q Download the complete project to the
Fle Edl ¥fw Inset Opfons Window Hel CPU: Select the ”Getting started”
ELE IR e e project from the project window.

121 Contral e CPU Cniline &

e Right-click on the project to open the
context-sensitive menu. Select Down-

load to CPU.
: : All project data are downloaded to the
B CPU, including the hardware

configuration.

I Crassreferc

You can also choose to download only
specific blocks or only the hardware
configuration to the CPU.

EPngram

i 6 In this example, we have selected the
5 pezibies hardware configuration for download.

[ DBL:Petral

10.9

Ensurg Program Consistency

Al
Print

o rcy New
T | o
Upload to Pragramming Device (PG

In this example, we have selected a
single block for download.

Loy
Enzure Program Consistency E::: Ea::?
iz 1B Fepafe .
e Depending on the selected elements,
STEP 7 Lite lets you perform an
("~ The view “Online CPU” has Upload to Programming Device (PG).
g changed.

<, STEP 7 Lite - Getting Started <, STEP 7 Lite - Getling Started
View Inseit Options Window Help File Insent Oy indow  Help

| & Al Waiatae SN G Bm|o | =8 Wb [ SN A [ oo | Click on Online CPU.
[ (21 Cortrolthe CPU Onine A 3 121 Contral the CPU Oniine |
You are shown all CPU data.

— Project (Offline view)
= Data on the PG

| — Online CPU (Online view)
= Data on the CPU

4} FB|f:Engine

2
)
%
Y
%
Y

13 ogf ain_progran 1
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The cyclic program
processing is displayed.

STEP 7 Lite - Getling Started
nset Options Window  Help

“ P AEISIEE L E N T T )

2 pro
5 ooais ofs
T retran
) ooz
5 oouren
T rovenafe
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How to switch on the CPU and
check its operating status

Set the mode selector switch to RUN-P
mode. The green RUN LED is on and
the red STOP LED is off. The CPU is
ready for operation.

Check the CPU:
When the green LED is lit, you can
start your program test run.

The LED stays red if an error has
occurred. Click on the "DIAG” button to
view the diagnostics buffer for error
evaluation (also refer to the section
"Module status and error history”, Page

[2.5)]

Check in STEP 7 Lite:

STEP 7 Lite follows a CPU transition to
RUN-P mode. Cyclic program
processing is indicated by a green
background.



A
A

Memory reset:

System function blocks (SFBs) and system
functions (SFCs) are retentive in the CPU,
irrespective of memory reset. The CPU provides
these operating system functions. You neither
have to download them, nor can you delete them.

How to download specific blocks:

You can increase error response under live
conditions by downloading single blocks to the
CPU. To enable block downloads, the mode
selector switch at the CPU must have been set to
"RUN-P” or "STOP” position. Blocks downloaded
in "RUN-P” mode are enabled instantaneously.
Here, note that:

If error-free blocks are overwritten by faulty
blocks, the result is a malfunction of your system.

The CPU goes into STOP mode if you neglect
the order in which blocks are loaded (e.g. a block
that does not yet exist on the CPU is called in
OB1.

CPU 31xC:

The mode selector of a CPU 31xC does not ship
with a rotary switch, but a toggle switch and there
is no RUN-P mode. However, the memory reset
procedure is the same. You wil find information on
Micro Memory Cards via:

F1 > Index > Micro Memory Card.
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Program test
run




Program test run

Performing a program test run
with program status

STEP 7 Lite lets you perform a
program test run on the PLC. Following
test run options are available:

1. Test run with program status — for
monitoring the program cycle (see
Page 11.3/to 11.5).

2. Test run with variable table — for
monitoring and controlling
addresses, e.g. inputs, outputs,
memory bits (see Page 11.6 to
11.10).

Requirements for test run with program
status: The complete program must
have been downloaded to the CPU.
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@E\Ie Edit Yiew |nsert

=4 STEP 7 Lite - Getting Started

in_Program -

Project]

CtiltF7
Lall Environment...
Dperation.

» it | K2 || RO

IodifyAddiess

WadiAddiess to 0

Madifaddress ta il

Bemove Addiess Force

] Symbol table
2| Manitor/Modify

A Cross-references

£ Project documentation
1% program

) DE3:5_Data
i} FC1:Fan
[5) DB2:Diesel
(5] DB1:Petral

0B1: Main_Program "Main Pro
Comment:

Hetwork 1: Conmecting in Ser

Comment :

NE' T 7 Par

Comment :

Type Start walue Comment
cLas BVTE Bits 0-3 = 1 fCaming ev
M_L BVTE 1(<ald restdt scan 1 of]
loRIT BVTE 1 (Pricrity of 1 is lowest
I BVTE 1 (Organizatfon block 1.
aram fweep (Cycle)”
s

Key_2

"Green_Light"

alle

——

"Red_Light"

a4

Comment :

Hetwork 31 o0 [0ET; Mecoll Memory foncrion

-4

Preparations

Establish an Online connection.

Set the key switch on the CPU to RUN
or RUN-P mode.

For network 1: Wire the series circuit.
For network 2: Wire the parallel circuit
(see the graphic)

Open the "Getting Started” project, or
one of the sample projects, you have
downloaded to the CPU.

Open OB1.

Monitoring

Call the monitoring function via Test >
Monitor. This function is only available
after you "Connect Online”.

The black network circuits are now
displayed in color.

GREEN circuit: Current flow.
RED circuit: No current flow

Now close all pushbutton contacts in
your test assembly, one after the other
and monitor:

- In STEP 7 Lite: How the circuits
change their color.

- At the modules: How the LEDs of

the I/0 modules are switched on
and off.
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11.4

Program test run

OBl: Main_Program "Main Program Sweep (Oyclel"

Comment:

Network 1 : Connecting in Series

Comment:

Network 2 : Conmecting in Parallel

Comment:

"Kay_3" "Red_Light"
.

"Key_1" "Key_2" "Green_Light"
T T o
--------------------------------------------------------- R

OBl: Main_Program "Main Program Sweep (Dyclel"

Commemnt:

Network 1 : Connecting in Series

Commemnt:

"aresn_Light"
i

Network 2 : Connecting in Farallel

Commett:

Eey_3 "Red_Light"
| | 1
{ |
Key_4
{1
0B1: Main_Program Ferindically Processed Main Program =
—
Camment:
Network 1: AND Function !
Camment:
. . RLO STA]  ACCUL
A key 1 0 [0 i
A TRey 2" 0| o0 0
= "Grean_Light" oo i
. v
Network 2 : OF Function E
Camment: —
RLO STA]  ACCUL
o ke 30 0 [ o 0
il ey 4" 0|0 i]
= "Red_Light" o |0 i
. v
Network 3: SR (Set, Reset) Memory Fumction :
0Bl: Main_Program Pericdically Processed Main Program =
Comment: —
Network 1: AND Function
Comment:
. . RLO STAT  ACCIL
A Key 1 1|1 i
A Ky 2" 11 il
= "Grean_Light" T 1 i}
bl v
Network 2 : OR Function E
Comment: -
RLO STAT  ACCIL
o “Kay_3" 1| 1 o
i "Key 4" 11 il
= "Red_Light" I il
El v
Network 3: SR (Set, Reset) Memory Function z
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Testing in LAD

Leave all pushbutton contacts open.

In network 1 and 2, the current circuit
is closed upstream of pushbuttons 1, 3
and 4. This circuit is indicated in green
color. There is no current flow down-
stream of pushbuttons 1, 3 and 4; this
circuit is indicated in red color.

The coloration indicates that the logical
operation result is correct up to this
position.

Now close pushbutton contacts 1, 2, 3
and 4.
All circuits are now under current.

If you have opened one of our sample
projects, you can follow the comments
to see which diodes should be lit on
the 1/0 modules.

Testing in STL

Leave all pushbutton contacts open.

STL shows in a table listing the
— Logical operation result (RLO)
— Status bit (STA)

— Accumulator (ACCU1).

Now close pushbutton contacts 1, 2, 3
and 4.

The logical operation result is correct
at all positions.



Testing in FBD

A —— --o Leave all pushbutton contacts open.
"Kay 1" -2 Voo lereenlight’
Network 2 : OR Function
Commant:
w0 eden
e
. - e Now close pushbuttons contacts 1, 2, 3
My 1" ] "Grasn_Light" -T™
oy 21 | ] = and 4.
The coloration indicates that the logical
network 2 o functien operation result is correct up to this
position.
MRey_3" 1— ==L "Red_Light"
"Key_4”1— -—I -

o Disable Test > Monitor. Close the
window.

Under Options > Settings > Block editor you
can modify the type of presentation of test
results.

Further information is found via F1 > Content >
Debugging > Testing using program status.
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Program test run

Monitoring and modifying variables

Start monitor

Monitor addresses

=4 STEP 7 Lite - Getting Started - [Monitor/M odify]
ﬁEile Edit View Inset Test Options Window Help

Stantimodify Monitor/Modify
expand or
Modify addresses reduce

A= E

Z] Getting Started
Il] Hardware
Eﬂj Symbol table

i odify]

M Cross-references

g Project dacumentatian
1 Program

[ DB3:5_Data

i FFCL:Fan

|5 DB2:Diesel

[=) DBL:Petral

i} FBL:Engine

{ } OB1:Main_Program

11.6

|2y Wb [ SF | i mBX [ oa | o

g [2] Control the CPU Online £

Online-CPL

Monitor/Modify
Variable Table VAT L = B IManage Table... | Expanded !
Status | Address Symbol tatus Malue | Display Format §Moflify Yalue | Comment
OB1 Metwork 1
0.1 Key_1 %&[ FALSE BOOL
0.2 "Key_2" I FALSE BQOL
Q4.0 “Gresn_Light" W FALSE BOOL
OBl Network 3
I0.5 "automatic_on" v FALSE BOOL
0.6 "Manual_On" v FALSE BOOL
04,2 "Automatic_Mode" v FALSE BOOL
Calling FE1 to Switch On the Petrol Engine
1.0 "Swikch_On_PE" v FALSE BOOL
I1.1 "Switch_OfF_PE" v FALSE BOOL
I1.2 "PE_Failure" v FALSE BOOL
Q5.1 "PE_Preset_Speed_Reached" [ FALSE BOOL
5.0 "PE_On" v FALSE BOOL
Calling FE1 to Switch On the Diesel Engine —
I1.4 "Switch_on_DE" v FALSE BOOL
1.5 "Switch_Off _DE" v FALSE BOOL
I1.6 "DE_Failure” r FALSE BOOL
Q5.5 "DE_Preset_Speed_Reached" [@ FALSE BOOL
5.4 "DE_on" v FALSE BOOL
Speed Monitoring For Petral Engine
W2 "PE_actual_Speed” ~ DEC
DE1.DEWE | "Petrol’ Preset_Speed v 1500 DEC
5.1 "PE_Preset_Speed_Reached” [ FALSE BOOL
Speed Monitaring For Diesel Engine
M4 "DE_Actual_Speed” v DEC
DEZ.DEWE | "Diesel" Preset_Speed ~ 1200 DEC
Q5.5 "DE_Preset_Speed_Reached" | [ FALSE BOOL |
I ] | |
-
£b Monitar i [Modify |
.ﬁl MonitorModify J‘E Monitor /Force
Sl RN | [ Abs | | Chg

Call monitor/ modify

table

Input area for creating the variable

You can monitor addresses by writing
them to the variable table. Condition is
here that you are Online to the CPU.

You can modify addresses by specify-
ing a modify value and then checkmark

Display area for status value e.g.
“true” or “false”

them. Also required: Online connection
and CPU in RUN-P mode.

Input area for modify value
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How to create the variable
table

,5TEP 7 Lite - Gelting Started - [Monitor/Modily]
afy Fle Edit Yiew [nsent Test Options window Help

S Hv W dd 5o 2 0 Open your "Getting Started” project.
H 2 comrare cu cfne 2 LIS ALLT Double-click on Monitor/Modify.
@nable Table VAT 1 v) B Manage Table. .. Expanded
7Status Address Symbol = Status Walue | Display Format | Modify Walue - Comment e In the Variable table field’ Create a
0.1 "Rey_1" v FALSE BOOL ” ”
] ﬂ oy 2 \!7 FaLSE | B00L new table under the name "VAT 1”.
1 Q4.0 “Green_Light" e FALSE BOOL T T
5] setng arad S| — b Foise [ poor ; " ;
e I T |[&__Fas | eoo o Enter all variables for the "Getting
&3 Symbol table allin 0 Switch On Ehe
A I R e R — started” sample,or only the variables
M Cros — 1 1.1 ::Sw\tthioff;PE" v FALSE BOOL ’ .
T T R | e 1 you want to modify.
‘H%UE';?: cLchJ ] = “PLO" . —— Fact Caling FB1 to Switch On the
S o ] Y b Foise [ poor To do this:
(5 pBziDissel (T e ::DE_FaWure“— 7 Fase BOOL 0 do IS:
Soored B S E i eielly is] o e — Enter "101.1” in the Address column.
D oetanfrogon® || T w9 pctua_speor” P o be Press Return to have "Key_1" automati-
1 DE1.DEWE | "Petrol* Preset_Speed v 1500 DEC .
R il e e TR cally inserted from the symbol table.
1\ woows e et J o | o Complete the table as in our figure.
i "DE_Preset_Speed_Reached) [F FALSE BOOL | vl N
_ You can also position the cursor in the

address column and select the address
from the list via shortcut Ctrl + j.

You can also copy the variable table
from one of the sample projects.

Open one of the sample projects in a
° second instance of STEP 7 Lite.

Again, click on Monitor/Modify to open

VAT 1.

Highlight the complete table via

Ctrl + a and copy it to the clipboard via

Ctrl + c.

e Go to your "Getting Started” project.
Paste the data from the clipboard to
your file via Ctrl + v
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Program test run

How to monitor variables

When monitoring the variables, you can
perform program test runs as well as
check your hardware for error-free
functioning.

0 Close contacts "Key_1" and "Key_2” in
your test assembly.

Vorcble Table —vaT 1 - D vanage tete.. | Eowded |
Status | Address | Symbol 3 Display Format | Modify Value  Comment
= il OB1 Network 1 CI' k M 't
- 0.1 “Key_i" ¥ TRUE BOOL ICK On onitor.
3 - 0z ey 2" 5 TRE BoOL . . .
Q4.0 “Green_Light” V¥ TRUE BOOL N th t t I h ghl ght d
m = BT NewrkS OW, € status value Is ni | ed on
1] cetting started w|| 05 uomatic_Or" ¥ Fase | sool bl b k d I d th
W Harcna al| = 05 Manudl O ¥ Fase | | ecoL a ue pac g round color an e
Q12 ‘Automatic_Made' ¥ FALSE BOOL
Caling FEL to Switch On the Petrol Engine H b I t d
10 [Seich on e o variables are monitored.
1.1 “Sitch_OFf_PE” =
.2 "PE_Faiure” 5
i Profect 5.1 "PE_Preset_Speed_Reachfid" O
= program 1 5.0 “PE_On” o
5 DBsi5_Data B Caling FEL to Switch On the Dissel Engine
o 14 "Switch_n_DE" 0
A FeiFan = 15 "Switch G DE" o
5 pB2iDiesel 1l I3 "D Faiure” =
() DB1:Petral L] 5.5 "DE_Preset_Spsed_Reachld" X
4} FB1:Engine B 54 "DE_on” o . . :
_ Speed Manitoring for Petrol Engine
(e REa w2 "PE_Actusl_speed” [CAN] DEC
DB1.DBWE | "Petrol’ Preset_Speed [CAE] DEC
51 "PE_Preset_Speed Reachfld" [V FALSE| | BooL
Speed Maritoring for Dizsel Enine
M4 "DE_Actual_Speed” 2N | | DEC
DBZ.DBWE | Diesel" Preset_Speed v im DEC
55 "DE_Preset_speed Reachfd’ [0 FALSE| | BooL |
% Monkor N

CLICKI
11.8 e You can monitor,

- how the displayed value in the
Status value column is toggled
from "FALSE” to "TRUE” and

- at the same time, how 1/O module
LEDs are switched on or off when
you press any of the pushbuttons
on your test assembly.

° For your program or hardware test run,
perform a check the plausibility of your
combination status
— Pushbutton contact open/close
— LED on/off
— Variable true/false.
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How to modify variables

While you are modifying variables, you
can assign them values in order to
simulate specific program runtime
situations.

Example:

0 For modifying, your CPU must also be
set to RUN-P mode. In this case,
Monitor stays enabled.

*3 STEP 7 Lite - € etting Started - [Monitar/Modify]
o) Fle Edit Vil Inset Test Options Window Help

6 In the Modify value column, enter the
value "TRUE”, for example. This

7| ohe st | k2

Varisble Table VAT 1| h2 By Hansge Teble) . | o= | y y
Stotus | Address | symbol Stotus Vale | Display Format | Modify Falue | Comment
bl Hetwork |
\ & 0.1 Koy 1" B TRUE sool {7 YW mel )
§ m & 0.2 “Key_2" ¥ TRUE BOOL
Q4.0 “Green_Light" V TRUE BOOL C h k k th t' b t bl
CCTo—) | eckmark the options box to enable
5] Getting Started ] 0.5 “Aukomatic_on” V. AFasE  sool — . . . .
.6 “Manual_on" ~  JFALsE BOOL th d fy I Th b d pl y d
1l Hrcere N X R € moairy value. IS DOX IS displaye
Caling FE1 to Switch on the Petrol Engine . .
0 e on fE s oo immediately after you have entered the
01 "5 witch_GFF_PE" ALSE 0
1.2 "PE_Failure” ALSE 0 H
ShProject 5.1 “PE_Preset_speed Reached" ALSE o n |Od |fy Value.
4 Program L] 5.0 PE_On" v ALSE 0
) DB2:5_Data m Caling FE1 to Switch On the Diesel Engine:
- 14 “Switch_on_DE" 0
I = s “Switch_GFF DE" 0
[ DB2:Diesel L 116 "DE _Failure" v 0
5] DBL:Petrol m 55 "DE_Preset_Speed_Reached"” 0 11 9
£} o1 Engne Y 54 e o’ o : —
. Speed Maritoring for Petral Engine
{7} OB1:Main_Program B MWz “PE_Actual_Speed” {2 (] DEC
DB1.DEWE | "Petrol’ Preset_Spesd [ () DEC
Q5.1 “PE_Preset_speed Reached” |V JFALSE BOOL
| | Spesd Moritoring for Diesel Engins . .
w4 “DE_Actual_Speed” [z 0 DEC — CI k M d f
escovs ‘oo o et | fiaoo | onc ICK on Noadity.
®s5 “DE_Preset_Speed_ Reached” |V JFALSE BOOL
|
> monitor » Moy

CLICK I—

e Monitor the effects of the modified
variables in the Status value column.
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11.10

Program test run

BOOL
BOOL
BOOL

BOOL
BOOL
BOOL

Status Wfalue | Display Format | Madify Yale | Comment

v
2

CB1 Network 1
TRUE
TRUE

OB1 Network 3

Calling FB1 to Switch On the Pel

Calling FB1 bo Swikch On the Di

peed Monitoring for Petrol En

Varizhle Table
Status | address | Symbal
& 0.1 Key_1" ¥ TRUE
& 10.2 “Key 2" P TRUE
1 Q40 "Green_Light" F  TRUE
) Getting Started m|| | 0.5 “putamatic_on" ¥ FALSE
o Hord || — 0.6 “Manual_on" P FAlsE
Wy Hardware O Q4.2 "Automatic_Mods" F  FALSE
&5 Symbal table
I -] onicorviodify} O 1.0 "Switch_On_PE" P FALsE
3 Cross-references ] 1.1 "Switch_OFf_PE" P FAlSE
] .z "PE_Failore” P FAlSE
255 Project documentation J Q5.1 "PE_Preset_Speed_Rearhed” [ TRUE
3 Program B ] Q5.0 "PE_On" ¥ FALSE
() DB3:5_Data W
N ] L4 "Siitch_On_DE" ¥ FAlSE
e ~ ] L5 "Siitch_OFf_DE" P FAlsE
() DB2:Diesel &) T L6 “DE_Failure” P FALSE
[ DBL:Petral m| [ Q5.5 "DE_Preset_Speed_Reached” | TRUE
£} FBLEngine m|| Q5.4 "BE_on" ¥ FAlSE
{F COB1:Main_Program B | M2 "PE_Actual_Speed” [ 1500
1 DE1.DBIWG |"Petrol Preset_Speed [ZRE
| Q5.1 "PE_Preset_Speed_Reached” [P TRUE
& M4 "DE_Actual_Speed” ¥ 1200
] DE2.DBW6 | "Diesel Preset_Speed ¥ 120
] Q55 "DE_Preset_Speed_Reached [P TRUE
% Manitor

i Modfy

Wariable Table

[ wae

Monitor/Modify

n the Petfol Engine

©n the Diefel Engine L

Petrol Engifle

Diesel Enifle

Status | Address | Symbol Status Yalue | Display Format | Modify Valus | Comment

] 0OB1 Network 1
= 101 "Key_1" ¥ TRUE BOOL W TRUE
8] 02 "Key 2" ¥ TRLE BOOL @ TRUE
] Q40 "Green_Light” ¥ TRUE BOOL

OB1 Network 3
| 105 "Automatic_On" ¥ FALSE BOOL
] 106 "Manual_on" ¥ FALSE BOOL
] Qt2 "Aukomatic_Made" ¥ FALSE BOOL
] Calling FB1 to Switc}
] L0 "switch_On_FE" ¥ FALSE BOOL
] Il "switch_CFf_PE" ¥ FALSE BOOL
] Lz "FE_Failre" ¥ FALSE BOOL
] Q5.1 "FE_Preset_Speed Reached” |7 TRUE BOOL
] Q5.0 "PE_Cn" ¥ FALSE BOOL

Calling FB1 to Switc}
| L4 "Switch_On_DE" ¥ FALSE BOOL
| L5 "Switch_OFf_DE" ¥ FALSE BOOL
] L6 "DE_Faiure" ¥ FALSE BOOL
] QE5 "DE_Preset_Speed_Reached” ¥ TRUE BOOL
] Q5.4 "DE_on” ¥ FALSE BOOL
] Speed Monitoring fi
= w2 "PE_Actual_Speed” ¥ 1sm0 DEC [N
] DB1.DBWE | "Petral” Preset_Speed ¥ 1s00 DEC
] Q5.1 "FE_Preset_Speed Reached” ¢ TRUE BOOL
] Speed Monitoring f
& MW "DE_Actual_speed” ¥ 1200 DEC ¥ ilem
1 DB2.DBWE | "Diesel” Preset_Speed ¥ i2m0 DEC
| Q55 "DE_Preset_Speed_Reached” |[@ mr EoaL

Monitor Mode End scan cycle permanently ¥

» Monitar

I Horitor Now 9 Modify

Modfy Mode

IF Modify Mow

i MonitoriModfy /2@ Monitor/Farce
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You can control binary as well as non-
binary addresses. For the latter, you
should first select the display format
and then enter a respective modify
value.

If you specify DEC for controlling
speed setpoints in the Display format
column,

you can enter the speed modify values
”1200” and "1500” in decimal format.

A cell highlighted on a red background
color indicates that you have entered a
value which is incompatible to display
format. In this case, the Modify value
column does not display the option
boxes anymore.

You can change the display format of a
variable, after you have clicked on the
type in the Display format column.

Expanded view
Monitor/Modify

You can choose between different

monitoring and modifying modes in the
expanded view Monitor/Modify e.g. you
can choose whether the control value:

— should be set only when the cyclic
status of OB1 is defined, e.g., when
the cycle starts or

— or immediately in the middle of a
running program.



Error
diagnostics



12.2

Error diagnostics

A quick glance at HW diagnostics

Diagnosable modules are displayed
7 Global module data — with status information
Open project via
File 8 Detailed data — with detailed error descriptions

Connect online 9 Show diagnostic buffer

‘__- STEF 7 Lite - Getting Started - [Hardivare - Project]

w  Help
- Project
ck 3 ]
Module status | Module Order number Ease address
Z CPU 315 6ES7 315-1AF01-0AE0
3
4 5M 32+ [ 6EST 32* standard-5M D:
] 5M 32+ O 6EST 32* standard-5M Dr
]
i 7
J Getting Started ! 5
[ = ] :j 9
= 10
] Symbol table 1 3456 78 9101l i
ﬁ MonitorfModify
M Cross-references 1
|
38 Praject documentation | Moduls CPU31S Systbm SIMATIC 300
i
ﬂ' Program o = Wersion Order no.f desfription | Component Release
(5 0B3:5 Data & 1] 345675891011 6ES7 315-16F0)-0AB0  Hardware 2
L} FCL:Fan &
5 DB2:Diesel L]
5 DBL:Petrol ]
{_F FB1:Engine ()]
{7} 0B1:Main_Program 78 91011 o g Addipss:
Slat: 2 ddble width: 1
Status: Module Ok, J
Symbols J
O RUN
& STOP Update
& HOLD Expanded diagnostl infarmation,., . |
@30 Error
OnI\ne-CPLI '= Hardware Comparison H; Hardware Configuration b Hardware Diagnostics
= Abs
All information on
; ordering parts
e Note operating mode CPU

Note hardware group error messages

° View: call hardware diagnostics °

STEP 7 Lite offers extensive error
diagnostics at a glance after a hard-
ware error has occurred in the PLC
station. The code number will indicate
the diagnostics path. This view is only
available in online mode.
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An error has occurred?

The status of a PLC in your plant has
changed to STOP. The CPU key switch
is set to RUN position.

A hardware error has occurred.

Troubleshooting

Set the key switch to STOP position.

Open the project which belongs to this
PLC station and in which the hardware
configuration error has occurred.

o Establish an Online connection
between the PG and the PLC (compare 12.3
Chapter [10).

o You already know that the CPU has
changed to STOP mode. You need this
information, for example, in situations
not allowing visual contact to the CPU

~,STEP 7 Lite - Getting Started - [Hardware - Project]
Wy Fils Edit Yiew Inset Options Window Help . . . .
TR T o during commissioning.
%o ANl Ml Hardware - Project
Rack | ack 1 | Rack2 | Rack |
' Slot | Module status Module Ord be B ddh
i —+ 2 & Enor CPUSLS  6EST 315-1AF01-0AB0
= a
Ty e
2l ! 2 .
: 1 5 Double-click on Hardware, on the left
: R -
b 10 . . .
BN side of your project window.
3¢ crossrefs LS i
5 Praject docum, ) Mol PUSLS tem SIMATIC 300
4 Frogram CLICK | v der no ) H H H
Bomsim | ol (IR e B S Open the Hardware Diagnostics view
FC1:Fan - T
) DB2:Diesel Y 0]
) DB1:Petral L]
£} FBLEngine -] R
{7} OBL:Main_Program 1 12 456 78 0Ll Rack 0 Address:
Slat: z todule width: 1
Staus: Fauky madule g
CLICK | A pictogram identifies the defective
J . . .
module in the rack. Click on this
Symbols
o _ : module.
@ sTOP
* HolD == Expanded diagnostic information. .
® Error
\ Project. (TTEeN] L Hardnare Comparison ) [ Hardware Corfiguation ;[

CLICK I
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Error diagnostics

ZREPI- B LD = Bl = You will receive a plain text message:

Wy Fie Edt View Inse Oplions Window Help
|4 | | &

1B 121 Soniral the CPU Onine A

H|oa

— Module O. K.
— Faulty module.

Rack0 | Rack 1 | Rackz | Rad
Slot | Module status Module

dl

Order umber Base address

® Ewor  CPUSIS | 6E57 315-1AF01-0ABO

0K, |sM3z°DI | 6ES7 32" standard SMDI |10
ok 32" DOf 6ES7 32" standard-SMDO_|Q ¢
8
a
&5 Symbol table 0
ol Monitorviody i
B Crossteferences
(8 Project documentation Hadule: CPUEIS System SIMATIC 300 If d f th 1 f t'
 progren ® you needa rturther information,
@ = Wersion: Order o, descrifition | Comporent | Release
L 6ES7 315-1AF01-(B0  Hardware H I I' k E d d d' t'
Shrcuran B please CliICK on EXpande lagnostics
) DB2iDiesel L | - -
Qo @ information.
4} FB1 Engine L]
7} OB1:Main_Program B 123456788911 Rack: o Address:
Slot: 2 Madule width:
Staus: Faulty module g
Symbols
@ RN - - ]
® Holo Expanded dagnostic information. .
& Error
Online-CPU BL Hardware Comparison retion ; [} Hardware Diagnos

12.4
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Module status and
error history

STOPRP, RUN, HALT, ... OK, error, ... Call additional data to
CPU

odule Information - CPU 315 ONLIME
Operating mode of the CPU: (% STOP Module Information: #7e Error
I
Time System ] Performance Data ] Communication ] General
Diagnostic Buffer I Stacks ] fdemary ] Scan Cycle Time

Events: r ™ Display evenis in hex famat

i) k.
0212/02 ed by stop switch being activated
02/12/02  Mode transition from STARTUP to RUN
02/12/02  Request for manual warm restart
02/12/02  Mode transition from STOP to STARTUP
R : 0212/02  Memary reset executed
11:50:24:693 am 02A12/02  Memary reset started by PG operation
11:27:53:824 am 02A12/02  Memomn reset executed j Detalls on mar-

10100 EventID: 1643922 ked events in
BAF: backup voltage failure on central rack ——— . . ’
08 number: 81 diagnostic buffer

OB not faund, or dizabled, or cannot be started in the current operating mode
External emror, Incoming event

Detals an Event:

12.5
Save Az | Settings... | Help on Event J__e He|p on dISplayed event
Help J Update ‘ Frrint.. ‘ Cloze
Filter for events to be displayed Before you go ahead and remove a
in the diagnostics buffer module you consider to be faulty, call

the Module information function (Call,
see Page 12.4) to check its status.

- - - The diagnostics buffer, for example,
Save diagnostic buffer in TXT records errors and all CPU events. You

format will need this information especially in
situations requiring the distinction
between a sequential error and the
actual error event.

Further information is found via F1 > Index >
Calling the module information.
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If a wire break has occurred:
Check the wiring or whether any measuring
range modules are inserted incorrectly.

When the CPU goes to STOP:

Evaluate message output from the diagnostics
buffer. The fastest possible way to access this
buffer is to click on the "DIAG” button in the CPU
operating panel.

With faulty module:
Switch off load voltage before you remove the
module.






13.2

Index

A

Absolute address|4.8//5.2
Absolute programming 5.2
Address 0.2

Apply|4.15/ 6.8, 6.14 6.20
Assigning module parameters 4.6
Automation License Manager 1.10

B

Backup battery [10.2
Basic help 2.9
Block calls|7.14
Block editor 6.4

c

Changing the programming language 6.4
Circuit 6.9

Comb connector 10.2

Component checklist|1.5

Computer|1.5

Configuration errors 4.10

Connect Online|10.3

Contro| 11.9

Copying the symbol table 5.5

CPU memory reset|10.6, 10.7//10.8

CPU operator panel 2.5

Creating a variable table 11.7
Cross-references| 6.24

Customize the programming interface|6.11

D

Data types 5.6

DB 6.5

Defining safety requirements| 3.5
Diagnostics buffer 12.2

Diesel engine 3.3

Direct Help 2.9

Documentation|1.5

Downloading a program to the CPU [10.9
Downloading the hardware configuration 4.16
Downloading the program 10.6
Downloading specific blocks 10.11
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E

Editing the variable declaration table 7.4

Engine On/Off circuit 7.6
Error diagnostics 12.2
Error history 12.5

Error messages|2.10

Establishing an Online connection 10.4

F

FB 6.5

FBD 6.2

FC6.5,8.2

File handling|2.7

Flip-flop 1.3

Function|8.2

Function block 7.2
Function block diagram|6.2

G
Global data block 9.2

H

Hardware catalog 4.6

Help 2.8

Hardware comparison 4.18

Hardaware configuration/ 4.6
Hardware diagnostics 12.2

Input 5.4
Inserting a new network 6.4

Inserting modules 4.9
Installation 1.8

Instance data blocks 7.12
Instant control [11.10

L

LAD 6.2

Ladder logic 6.2
Libraries| 2.5
License Key (1.8



Memory array 1.3
Memory module[10.2
Modifying variables 11.9
Module configuratior 4.2

Module parameter assignment|4.12

Module racks|10.2

Module status|12.5

Monitor [11.3,/11.8

Monitoring variables [11.6,/11.8
Motor bench 3.2

MPI cable|10.2

N
New block 7.13

New project 4.4

0

OB 6.5

Off delay 8.6

Offline|4.19

Online 4.19

Online/Offline comparison 4.17
Ordering numbers| 1.5
Overview 1.6

P

Parallel circuit 1.3

Parameter assignment 4.13
Petrol engine| 3.3

Physics/4.19

Pictograms 4.6

Pin needle|4.5

Power supply 10.2

Program download 10.6
Programming a function 8.6
Programming a timer function 8.7
Programming block calls 8.9
Programming language 6.2
Programming samples| 2.3
Program speed monitoring 7.7

Program status|11.2
Program test run 11.2
Project window| 2.4
Purpose of STEP 7 Lite 0.3

Q
Quick Help 2.9

R

Rack 4.2
Reference Help|2.10

S

Save|4.15] 6.8,/6.14,/6.20
Saving configuration data 4.14
Series circuit|1.3

Simulation software 1.5
Statement list 6.2

STLI6.2

STOP|12.5

Switching over symbolic/absolute program-
ming 6.4

Symbolic programming 5.4
Symbolic representation 6.7
Symbols 4.20

Symbol table 5.5

T

Test assembly 10.2
Testing 11.4
Timer function 8.6

\')

Variable declaration table 8.6

W
Wire break 12.6
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